summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-03-01 19:08:16 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-03-01 19:08:33 -0600
commiteb00909a232eec5a363fe6b44a31f3379d8167fe (patch)
treeaa9581e1fb28315d7667615d456cf2cf1bb91992 /gui-libs
parentdev-python/parameterized: Mark ALLARCHES (diff)
downloadgentoo-eb00909a232eec5a363fe6b44a31f3379d8167fe.tar.gz
gentoo-eb00909a232eec5a363fe6b44a31f3379d8167fe.tar.bz2
gentoo-eb00909a232eec5a363fe6b44a31f3379d8167fe.zip
gui-libs/xdg-desktop-portal-wlr: 0.2.0 bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild47
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild6
3 files changed, 51 insertions, 3 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/Manifest b/gui-libs/xdg-desktop-portal-wlr/Manifest
new file mode 100644
index 000000000000..158e2400ed7c
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/Manifest
@@ -0,0 +1 @@
+DIST xdg-desktop-portal-wlr-0.2.0.tar.gz 22260 BLAKE2B a1f3a8244b985874a0b663b311157bc2e2098b8c50b6e3688c89d1c7bf7c454048b359ad42b97edb2faae7b232cd5b6843c07098c07e1f97ede507995d214271 SHA512 9b01919b380510389710c005901810ac6fa00299f2b35a37fa949aab361438ab08c30fc95b88e1805dcea7e97ebe2d19111693f82eee545864077347d2659ca9
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild
new file mode 100644
index 000000000000..1aa36ee0f399
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for wlroots"
+HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ #KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.3.2:=
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14:=
+ elogind? ( >=sys-auth/elogind-237 )
+ systemd? ( >=sys-apps/systemd-237 )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=media-video/pipewire-0.3.2:=
+ >=dev-libs/wayland-protocols-1.14
+ >=dev-util/meson-0.50.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
index 1387d91cb4be..029d5a3963d4 100644
--- a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
@@ -22,7 +22,7 @@ IUSE="elogind systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
- >=media-video/pipewire-0.2.9:=
+ >=media-video/pipewire-0.3.2:=
dev-libs/wayland
>=dev-libs/wayland-protocols-1.14:=
elogind? ( >=sys-auth/elogind-237 )
@@ -33,9 +33,9 @@ RDEPEND="
sys-apps/xdg-desktop-portal
"
BDEPEND="
- >=media-video/pipewire-0.2.9:=
+ >=media-video/pipewire-0.3.2:=
>=dev-libs/wayland-protocols-1.14
- >=dev-util/meson-0.47.0
+ >=dev-util/meson-0.50.0
virtual/pkgconfig
"