summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-05 22:03:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-05 22:03:27 -0500
commitf5b2a27a36e8a997e732a0c16dd921cd0cf7c46b (patch)
treef9bef9350ca4d16cbc0a7b69c387cc35cabe9f52 /gui-libs
parentgames-rpg/freedroid: drop 1.0.2-r1 (diff)
downloadgentoo-f5b2a27a36e8a997e732a0c16dd921cd0cf7c46b.tar.gz
gentoo-f5b2a27a36e8a997e732a0c16dd921cd0cf7c46b.tar.bz2
gentoo-f5b2a27a36e8a997e732a0c16dd921cd0cf7c46b.zip
gui-libs/xdg-desktop-portal-wlr: 0.4.0 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.4.0.ebuild48
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild2
3 files changed, 50 insertions, 1 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/Manifest b/gui-libs/xdg-desktop-portal-wlr/Manifest
index 79a4e78a55ab..1c4a800d0a7b 100644
--- a/gui-libs/xdg-desktop-portal-wlr/Manifest
+++ b/gui-libs/xdg-desktop-portal-wlr/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-wlr-0.2.0.tar.gz 22260 BLAKE2B a1f3a8244b985874a0b663b311157bc2e2098b8c50b6e3688c89d1c7bf7c454048b359ad42b97edb2faae7b232cd5b6843c07098c07e1f97ede507995d214271 SHA512 9b01919b380510389710c005901810ac6fa00299f2b35a37fa949aab361438ab08c30fc95b88e1805dcea7e97ebe2d19111693f82eee545864077347d2659ca9
DIST xdg-desktop-portal-wlr-0.3.0.tar.gz 29340 BLAKE2B 848e3cb969a6d9f9cfcbb25336bd66bf75e2ae01fc5ba637950bb202399c2344f14cbc7a65c5940678bc4ca02134cee26ee425b88a91d050c6833c6098d34fd6 SHA512 2b01fab18296cb95cf659ff5a74ed6bf1482c033fdb274904bf2c3ea736dd3c8cb2e82f0662439a88f81ae86cc2fca2fbc3c1a9c72267ba126571973a7662e3d
+DIST xdg-desktop-portal-wlr-0.4.0.tar.gz 30776 BLAKE2B c4a6c07f57cc7cf16f16de43571bf9a281e647bcb1216da5a82e9c40d7a8344e78380b08a215a252011c9da8f97294aacc844d999095f4117ea26d17ff9ffec6 SHA512 544dea4601ce8aa8649d15b7c249aa5b0099fa5a6aec1b7a1433439265acede9ac442092da53080c36b372dd0ef5aaa15747b13a56f4a648e1c00ed3c2435e19
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.4.0.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.4.0.ebuild
new file mode 100644
index 000000000000..8642e22e21e1
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for wlroots"
+HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.3.2:=
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14:=
+ elogind? ( >=sys-auth/elogind-237 )
+ systemd? ( >=sys-apps/systemd-237 )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=media-video/pipewire-0.3.2:=
+ >=dev-libs/wayland-protocols-1.14
+ >=dev-util/meson-0.50.0
+ dev-libs/inih:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
index e5d42ca22778..8642e22e21e1 100644
--- a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
@@ -36,7 +36,7 @@ BDEPEND="
>=media-video/pipewire-0.3.2:=
>=dev-libs/wayland-protocols-1.14
>=dev-util/meson-0.50.0
- dev-libs/iniparser:0
+ dev-libs/inih:0
virtual/pkgconfig
"