summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-10-19 12:12:23 -0400
committerSam James <sam@gentoo.org>2023-10-27 04:17:58 +0100
commit89292d520bda0542b39856a858cd96da771c7b3c (patch)
treed8fe3a3d1f75c48de1f39a72694ecfeb7075cc6f /gui-wm
parentgui-wm/hyprland: add 0.31.0 (diff)
downloadgentoo-89292d520bda0542b39856a858cd96da771c7b3c.tar.gz
gentoo-89292d520bda0542b39856a858cd96da771c7b3c.tar.bz2
gentoo-89292d520bda0542b39856a858cd96da771c7b3c.zip
gui-wm/hyprland: drop 0.29.1
Signed-off-by: Julien Roy <julien@jroy.ca> Closes: https://github.com/gentoo/gentoo/pull/33416 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.29.1.ebuild119
2 files changed, 0 insertions, 120 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index d24c531125e4..425ab149ab04 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,3 +1,2 @@
-DIST hyprland-0.29.1.gh.tar.gz 14056843 BLAKE2B 9e9f1b15d354cf5e391b1add5dc5ce8cf2e4b206853465028a6170e613c7c5435e9a6e3318cd1006d3c2874d885128b95495bba08444fade0185b2a69d9ab950 SHA512 abbfd244b7473ec521a639b0d424e2873193ab9ef0d24e6272e15b79da9ade8ee56ea4cffdc328713f99600c1d320384839d32eb223034945659b015125e98b1
DIST hyprland-0.30.0.gh.tar.gz 14064946 BLAKE2B 188328ed08ca8a9db97ae94b77159f9ebe5361a050a177ec586f376b168dab4c9dcd6b6d71d3314e9470f46b57f0610a92cdfe73ff1704b9f55f21399895e69f SHA512 f8053c19460e7768aa00944d1fc624d85ff9e042d0750a74d28e08147fe50e45262bdb1c259642bb7241746a8fb967344841e58fa598213f8c333f15246f9c94
DIST hyprland-0.31.0.gh.tar.gz 14068621 BLAKE2B 272ba0c92ee6f8db623bb7b79a64ec1a3f2d2e0e1a8825ab7cc43e30dc64d77396ae014469a308c10deea0f9607680ff3a9328b747c82acccd5156e9d9c07cde SHA512 27798eba3bc430fe3689ecfb6ae38a59f48c39183c8cbd4fea8dca0a92a25941e6ee8b51d70f18498a3b0ef6c2575658299ee36ed6a6a93c7b54548ab64f07ca
diff --git a/gui-wm/hyprland/hyprland-0.29.1.ebuild b/gui-wm/hyprland/hyprland-0.29.1.ebuild
deleted file mode 100644
index 116dc4c643f0..000000000000
--- a/gui-wm/hyprland/hyprland-0.29.1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson toolchain-funcs
-
-DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
-HOMEPAGE="https://github.com/hyprwm/Hyprland"
-
-SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${PN}-source"
-
-KEYWORDS="~amd64"
-LICENSE="BSD"
-SLOT="0"
-IUSE="X legacy-renderer systemd video_cards_nvidia"
-
-# bundled wlroots has the following dependency string according to included headers.
-# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
-# enable x11-backend with X and vice versa
-WLROOTS_RDEPEND="
- >=dev-libs/libinput-1.14.0:=
- dev-libs/libliftoff
- >=dev-libs/wayland-1.22
- media-libs/libdisplay-info
- media-libs/libglvnd
- media-libs/mesa[egl(+),gles2]
- sys-apps/hwdata:=
- sys-auth/seatd:=
- >=x11-libs/libdrm-2.4.114
- x11-libs/libxkbcommon
- >=x11-libs/pixman-0.42.0
- virtual/libudev:=
- X? (
- x11-base/xwayland
- x11-libs/libxcb:0=
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
-"
-WLROOTS_DEPEND="
- >=dev-libs/wayland-protocols-1.32
-"
-WLROOTS_BDEPEND="
- dev-util/glslang
- dev-util/wayland-scanner
-"
-
-RDEPEND="
- ${WLROOTS_RDEPEND}
- dev-libs/glib:2
- dev-libs/libinput
- dev-libs/wayland
- media-libs/libglvnd
- x11-libs/cairo
- x11-libs/libdrm
- x11-libs/libxkbcommon
- x11-libs/pango
- x11-libs/pixman
- X? (
- x11-libs/libxcb:0=
- )
-"
-DEPEND="
- ${RDEPEND}
- ${WLROOTS_DEPEND}
- dev-libs/hyprland-protocols
- >=dev-libs/wayland-protocols-1.25
-"
-BDEPEND="
- ${WLROOTS_BDEPEND}
- app-misc/jq
- dev-util/cmake
- dev-util/wayland-scanner
- dev-vcs/git
- virtual/pkgconfig
-"
-
-pkg_setup() {
- [[ ${MERGE_TYPE} == binary ]] && return
-
- if tc-is-gcc; then
- STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
- grep GLIBCXX_RELEASE | sed 's/.*\([1-9][0-9]\)/\1/')
-
- if ! [[ ${STDLIBVER} -ge 12 ]]; then
- die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
- fi
- elif [[ $(clang-major-version) -lt 16 ]]; then
- die "Hyprland requires >=sys-devel/clang-16.0.3 to build";
- fi
-}
-
-src_prepare() {
- if use video_cards_nvidia; then
- cd "${S}/subprojects/wlroots" || die
- eapply "${S}/nix/patches/wlroots-nvidia.patch"
- cd "${S}" || die
- fi
-
- eapply "${FILESDIR}/hyprland-0.28.0-no-wlroots-automagic-r1.patch"
-
- default
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature legacy-renderer legacy_renderer)
- $(meson_feature X xwayland)
- $(meson_feature systemd)
- )
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install --skip-subprojects wlroots
-}