summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-04-16 16:23:56 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-08 10:29:09 -0500
commite9afb5379f855f05af863c7a2150a06a281282ca (patch)
treefcb03fe290c4c377db8f008234f21584124fdc3b /gui-wm
parentapp-shells/tcsh: Stabilize 6.24.00 hppa, #856970 (diff)
downloadgentoo-e9afb5379f855f05af863c7a2150a06a281282ca.tar.gz
gentoo-e9afb5379f855f05af863c7a2150a06a281282ca.tar.bz2
gentoo-e9afb5379f855f05af863c7a2150a06a281282ca.zip
gui-wm/sway: bump for new grimshot utility
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/metadata.xml1
-rw-r--r--gui-wm/sway/sway-1.7-r1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/gui-wm/sway/metadata.xml b/gui-wm/sway/metadata.xml
index 0f236d0a69f7..83ff81b0d4e2 100644
--- a/gui-wm/sway/metadata.xml
+++ b/gui-wm/sway/metadata.xml
@@ -26,6 +26,7 @@
something else.
</longdescription>
<use>
+ <flag name="grimshot">Install 'grimshot': script for taking screenshots</flag>
<flag name="swaybar">Install 'swaybar': sway's status bar component</flag>
<flag name="swaybg">Install 'swaybg': allows to set a desktop background image</flag>
<flag name="swayidle">Install 'swayidle': idle manager to run commands when user is inactive</flag>
diff --git a/gui-wm/sway/sway-1.7-r1.ebuild b/gui-wm/sway/sway-1.7-r1.ebuild
new file mode 100644
index 000000000000..ebf427818f84
--- /dev/null
+++ b/gui-wm/sway/sway-1.7-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ MY_PV=${PV/_rc/-rc}
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="grimshot +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag tray wallpapers X"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.6.0:0=
+ sys-auth/seatd:=
+ dev-libs/libpcre
+ >=dev-libs/wayland-1.20.0
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ media-libs/mesa[gles2,libglvnd(+)]
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ swaybg? ( gui-apps/swaybg )
+ swayidle? ( gui-apps/swayidle )
+ swaylock? ( gui-apps/swaylock )
+ wallpapers? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ X? ( x11-libs/libxcb:0= )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~gui-libs/wlroots-9999:=[X=]"
+else
+ DEPEND+="
+ >=gui-libs/wlroots-0.15:=[X=]
+ <gui-libs/wlroots-0.16:=[X=]
+ "
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ grimshot? (
+ app-misc/jq
+ gui-apps/grim
+ gui-apps/slurp
+ gui-apps/wl-clipboard
+ x11-libs/libnotify
+ )
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ virtual/pkgconfig
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature tray)
+ $(meson_feature X xwayland)
+ $(meson_feature swaybar gdk-pixbuf)
+ $(meson_use swaynag)
+ $(meson_use swaybar)
+ $(meson_use wallpapers default-wallpaper)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use grimshot; then
+ doman contrib/grimshot.1
+ dobin contrib/grimshot
+ fi
+}