summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-09-15 11:28:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-09-15 11:29:42 -0500
commitf0e47a143b5f10a611b7559f2b291b67bfeb217b (patch)
tree7269f912b52368c4f41503b9600954ce6c77a818 /gui-wm
parentdev-ruby/puppetdb-termini: cleanup (diff)
downloadgentoo-f0e47a143b5f10a611b7559f2b291b67bfeb217b.tar.gz
gentoo-f0e47a143b5f10a611b7559f2b291b67bfeb217b.tar.bz2
gentoo-f0e47a143b5f10a611b7559f2b291b67bfeb217b.zip
gui-wm/sway: cleanup
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/Manifest1
-rw-r--r--gui-wm/sway/sway-1.4-r2.ebuild119
2 files changed, 0 insertions, 120 deletions
diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index 6dee4daad21b..ff57f906082e 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1,2 +1 @@
-DIST sway-1.4.tar.gz 5514489 BLAKE2B 31eb1aee32079e643cc7a0263a097000c089e36916ea2a681e1ec696f8329e7ecfe3c8a981ec3b6d4e3dd99c8e263b2c208dbe602308d6bdaf4cdabbb3c10971 SHA512 3b280bdfdbdae8fb9b4f555bc630c64e7c1d09f7b2c783b99413863a6b620d50cd2b6d10d63e11fdfb9c678fce9a403228ac52fa69fb52561ffbd06790505a71
DIST sway-1.5.tar.gz 5535966 BLAKE2B e863e97ee897dcd1652d363a09b712932de55da08c88b4858f0aadc29b2cb19d2bda1e5e1184f4e4be6fa54a0136463556f9072f32e2b952d4f12ffd0ee9baf9 SHA512 702e44f8923a4ca05d831dd7ed76165654f113a8b2754d332c509ee844528f47c52b7f21deca78d4a79dad465cbcd0934574fff4ad9bb7a45aec3124dea5bca4
diff --git a/gui-wm/sway/sway-1.4-r2.ebuild b/gui-wm/sway/sway-1.4-r2.ebuild
deleted file mode 100644
index 80125677e211..000000000000
--- a/gui-wm/sway/sway-1.4-r2.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit eutils meson
-
-DESCRIPTION="i3-compatible Wayland window manager"
-HOMEPAGE="https://swaywm.org"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-else
- MY_PV=${PV/_rc/-rc}
- SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 x86"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
-REQUIRED_USE="?? ( elogind systemd )
- tray? ( || ( elogind systemd ) )"
-
-DEPEND="
- >=dev-libs/json-c-0.13:0=
- >=dev-libs/libinput-1.6.0:0=
- dev-libs/libpcre
- dev-libs/wayland
- x11-libs/cairo
- x11-libs/libxkbcommon
- x11-libs/pango
- x11-libs/pixman
- media-libs/mesa[gles2]
- elogind? ( >=sys-auth/elogind-239 )
- swaybar? ( x11-libs/gdk-pixbuf:2 )
- swaybg? ( gui-apps/swaybg )
- swayidle? ( gui-apps/swayidle )
- swaylock? ( gui-apps/swaylock )
- systemd? ( >=sys-apps/systemd-239 )
- wallpapers? ( x11-libs/gdk-pixbuf:2[jpeg] )
- X? ( x11-libs/libxcb:0= )
-"
-if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
-else
- DEPEND+="
- >=gui-libs/wlroots-0.10.0:=[elogind=,systemd=,X=]
- <gui-libs/wlroots-0.11.0:=[elogind=,systemd=,X=]
- "
-fi
-RDEPEND="
- x11-misc/xkeyboard-config
- ${DEPEND}
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.14
- virtual/pkgconfig
-"
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
- BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
-fi
-
-PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
-
-src_prepare() {
- default
-
- use swaybar || sed -e "s/subdir('swaybar')//g" -e "/sway-bar.[0-9].scd/d" \
- -e "/completions\/[a-z]\+\/_\?swaybar/d" -i meson.build || die
- use swaymsg || sed -e "s/subdir('swaymsg')//g" -e "/swaymsg.[0-9].scd/d" \
- -e "/completions\/[a-z]\+\/_\?swaymsg/d" -i meson.build || die
- use swaynag || sed -e "s/subdir('swaynag')//g" -e "/swaynag.[0-9].scd/d" \
- -e "/completions\/[a-z]\+\/_\?swaynag/d" -i meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=$(usex man enabled disabled)
- -Dtray=$(usex tray enabled disabled)
- -Dxwayland=$(usex X enabled disabled)
- $(meson_use wallpapers default-wallpaper)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
- "-Dbash-completions=true"
- "-Dwerror=false"
- )
-
- if use swaybar; then
- emesonargs+=("-Dgdk-pixbuf=enabled")
- else
- emesonargs+=("-Dgdk-pixbuf=disabled")
- fi
-
- meson_src_configure
-}
-
-pkg_preinst() {
- if ! use systemd && ! use elogind; then
- fowners root:0 /usr/bin/sway
- fperms 4511 /usr/bin/sway
- fi
-}
-
-pkg_postinst() {
- if ! use systemd && ! use elogind; then
- elog ""
- elog "If you use ConsoleKit2, remember to launch sway using:"
- elog "exec ck-launch-session sway"
- elog ""
- elog "If your system does not set the XDG_RUNTIME_DIR environment"
- elog "variable, you must set it manually to run Sway. See wiki"
- elog "for details: https://wiki.gentoo.org/wiki/Sway"
- fi
-}