summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-14 17:13:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:14 +0200
commite19edabff80707de8772078358c8a9ca1169ca91 (patch)
treeb15a6cde4e36de6ddebe6a9e3d015312dc40dc8d /kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild
parentkde5-functions.eclass: Update minimum deps (diff)
downloadgentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.gz
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.bz2
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.zip
kde-apps: Add KDE Applications 19.04.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild')
-rw-r--r--kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild b/kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild
new file mode 100644
index 000000000000..c2875fb209bf
--- /dev/null
+++ b/kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library for akonadi calendar integration"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+ !<kde-apps/kdepim-runtime-18.03.80
+"
+
+RESTRICT+=" test"