summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-09 11:59:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-09 17:37:35 +0200
commitb7219b50ea22bef8787fc2e9e438c7b927807ae6 (patch)
tree8870783b39780b4cee7873bd4562824c6c7ed774 /kde-apps/akonadi-search/akonadi-search-20.04.3.ebuild
parentkde-apps/akonadi-notes: 20.04.3 version bump (diff)
downloadgentoo-b7219b50ea22bef8787fc2e9e438c7b927807ae6.tar.gz
gentoo-b7219b50ea22bef8787fc2e9e438c7b927807ae6.tar.bz2
gentoo-b7219b50ea22bef8787fc2e9e438c7b927807ae6.zip
kde-apps/akonadi-search: 20.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi-search/akonadi-search-20.04.3.ebuild')
-rw-r--r--kde-apps/akonadi-search/akonadi-search-20.04.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/akonadi-search/akonadi-search-20.04.3.ebuild b/kde-apps/akonadi-search/akonadi-search-20.04.3.ebuild
new file mode 100644
index 000000000000..55035b999bd4
--- /dev/null
+++ b/kde-apps/akonadi-search/akonadi-search-20.04.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.70.0
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Libraries and daemons to implement searching in Akonadi"
+HOMEPAGE="https://invent.kde.org/pim/akonadi-search"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[tools] )
+"
+RDEPEND="
+ >=dev-libs/xapian-1.3:=[chert(+)]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[mysql,postgres,sqlite] )
+"