summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-04 13:24:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-04 14:20:58 +0100
commit956194b1b4912c106d3e41d55a42ff9b593c29d3 (patch)
treeb0fa8dfde3b77c1a36c82bb28b3babb2b02a6829 /kde-apps/akonadi-search/akonadi-search-21.08.3.ebuild
parentkde-apps/akonadi-notes: 21.08.3 version bump (diff)
downloadgentoo-956194b1b4912c106d3e41d55a42ff9b593c29d3.tar.gz
gentoo-956194b1b4912c106d3e41d55a42ff9b593c29d3.tar.bz2
gentoo-956194b1b4912c106d3e41d55a42ff9b593c29d3.zip
kde-apps/akonadi-search: 21.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi-search/akonadi-search-21.08.3.ebuild')
-rw-r--r--kde-apps/akonadi-search/akonadi-search-21.08.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/kde-apps/akonadi-search/akonadi-search-21.08.3.ebuild b/kde-apps/akonadi-search/akonadi-search-21.08.3.ebuild
new file mode 100644
index 000000000000..87f54707e06c
--- /dev/null
+++ b/kde-apps/akonadi-search/akonadi-search-21.08.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Libraries and daemons to implement searching in Akonadi"
+HOMEPAGE="https://invent.kde.org/pim/akonadi-search"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RESTRICT="test" # perpetually broken, bug 662378
+
+BDEPEND="
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[tools] )
+"
+RDEPEND="
+ >=dev-libs/xapian-1.3:=[chert(+)]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[mysql,postgres,sqlite] )
+"