summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 00:48:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 08:51:28 +0200
commitd91c5589f2317dcfa61e9b15a71341582c6d3537 (patch)
tree13f63c923413004219e299b4f3d4ef39aeffec56 /kde-apps/akonadiconsole
parentkde-frameworks: Add KDE Frameworks 5.71.0 (diff)
downloadgentoo-d91c5589f2317dcfa61e9b15a71341582c6d3537.tar.gz
gentoo-d91c5589f2317dcfa61e9b15a71341582c6d3537.tar.bz2
gentoo-d91c5589f2317dcfa61e9b15a71341582c6d3537.zip
kde-apps: Add KDE Release Service 20.04.2
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadiconsole')
-rw-r--r--kde-apps/akonadiconsole/Manifest1
-rw-r--r--kde-apps/akonadiconsole/akonadiconsole-20.04.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-apps/akonadiconsole/Manifest b/kde-apps/akonadiconsole/Manifest
index c7ebfa414891..61a6d1f87b82 100644
--- a/kde-apps/akonadiconsole/Manifest
+++ b/kde-apps/akonadiconsole/Manifest
@@ -1,2 +1,3 @@
DIST akonadiconsole-19.12.3.tar.xz 194080 BLAKE2B 411c3a7610c7437b87d4488741f8768bc36b9798b8c5a9b892a523c357a31b82d887309a753022f498ea9b1623259bfd2397615a617a64d8ad33497be2f257f3 SHA512 39131877e0bc7b09141e0d218a01eaa86bd3aa9963514eaa3f44fe510aa7a88b4478ddf1461fc1ce59084d0dfa34186d3d0e4ab8d4763204ba651e8ab4c7d355
DIST akonadiconsole-20.04.1.tar.xz 193596 BLAKE2B 0eabb7d4dabd296acf13696231ee65e0ee8671117916da88dbb673869f93f99ee83237bc05238b5cc1804e77e4e0715a39dd4f1aa193528fccb8bacaebd6703e SHA512 d0c344bcdd0f4bc8917710f771a875f6039bc0b27d86de1f49a54b7b5dd85b026f09d11e114be0090990f70560fe70768e7237268cd88deb51d3ffc2b8152ecb
+DIST akonadiconsole-20.04.2.tar.xz 193656 BLAKE2B 6e0fb55e11e954ea325b31da3eff475b95d5ed4a35a804e023cf4751bfe7be2303b7c0ddb74e6e4ef4c197535b46e9f1f9fe0bbe49b4f90918bc21fe71eb4c53 SHA512 be9f70b06e6c60a125044c433aadb82ffed745002a31456e8b6f3b6876411ecbf36d9947ad7a634e031253812e275a6392eb4feffad681d7881b3a363807daf3
diff --git a/kde-apps/akonadiconsole/akonadiconsole-20.04.2.ebuild b/kde-apps/akonadiconsole/akonadiconsole-20.04.2.ebuild
new file mode 100644
index 000000000000..c9aa76db293f
--- /dev/null
+++ b/kde-apps/akonadiconsole/akonadiconsole-20.04.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.70.0
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="Application for debugging Akonadi Resources"
+HOMEPAGE="https://techbase.kde.org/KDE_PIM/Akonadi/Development_Tools"
+
+LICENSE="GPL-2+ LGPL-2.1+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/xapian:=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-search-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"