summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:39 +0100
commitd7443e05892e21953f2476002a87f3c0213706bb (patch)
treebdc943e4106bc2c6f20218650cf96563b88f1827 /kde-apps/ark
parentsys-fs/zfs: drop old (diff)
downloadgentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.gz
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.bz2
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.zip
kde-apps: Add KDE Applications 17.12.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-17.12.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 45e8fe79e6e3..7f39907f0d96 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-17.08.3.tar.xz 1966132 BLAKE2B ec17cdd3d9682cbf2f533bb159fcc219c91426997120ac03fa4726123701b6e1d98686cdaa07330e541bd2a1189a920292c13932df824bb9855bc93c38c7c605 SHA512 c28eda02f561391a21723286de2b71b9d985a07edfabd510b690927ac598da7464b56ba6132bb0362a6fd7ddb35d99bcbeb8ef74b801cfbba22f6f6d91262fb8
DIST ark-17.12.2.tar.xz 1970240 BLAKE2B eb402da08903476f1ae14ff3921742a63242a2fbd1eb5702c794a52a5249342751b1a0a943d10a0516a7cb6da3bfd7a1c886d2d23a09c4b79022d96b86486008 SHA512 8b87bb8e96ed1483503ebd26ce505962cafe96b9294dac9dd548a0659c0ff8795cf1e699c86ec2168f761819906d8958cedbe3858e05d50f7cb41a9d780a78af
+DIST ark-17.12.3.tar.xz 1970120 BLAKE2B b8e14f6b5f541c514107cf76b612edd99d6e0d97dfbe7600349bdcf2bd5afbfd1fcaf256d0358ff0c8838d8334a14ddd1ac5d29ce9befebe960444e0828aba5e SHA512 2f32f0107afa20ef115caddaf3c7ce6be37a575c72ea440f571312309d945a0e0491a4327db379e8ca7622a2b5016c5b2bbbfb3377d3b4272430f85b23fbb911
diff --git a/kde-apps/ark/ark-17.12.3.ebuild b/kde-apps/ark/ark-17.12.3.ebuild
new file mode 100644
index 000000000000..c95527b9545e
--- /dev/null
+++ b/kde-apps/ark/ark-17.12.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}