summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-09 11:59:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-09 17:37:19 +0200
commit96d24338038dc5cb295344f763deb6e99c70ac40 (patch)
tree1349b6398d4fe541d28138cde76b51739596f20d /kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.3.ebuild
parentmedia-sound/elisa: 20.04.3 version bump (diff)
downloadgentoo-96d24338038dc5cb295344f763deb6e99c70ac40.tar.gz
gentoo-96d24338038dc5cb295344f763deb6e99c70ac40.tar.bz2
gentoo-96d24338038dc5cb295344f763deb6e99c70ac40.zip
kde-apps/dolphin-plugins-dropbox: 20.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.3.ebuild')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.3.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.3.ebuild
new file mode 100644
index 000000000000..9dea3e839107
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.70.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}