summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-29 17:02:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-29 17:52:18 +0100
commit85cf88558d2d732d73c9adc4ea1d9705987c3378 (patch)
tree32ddec743d5e6b4131deea71071903716432003b /kde-apps/dolphin-plugins-dropbox
parentmedia-sound/elisa: 21.11.90 version bump (diff)
downloadgentoo-85cf88558d2d732d73c9adc4ea1d9705987c3378.tar.gz
gentoo-85cf88558d2d732d73c9adc4ea1d9705987c3378.tar.bz2
gentoo-85cf88558d2d732d73c9adc4ea1d9705987c3378.zip
kde-apps/dolphin-plugins-dropbox: 21.11.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.11.90.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index 3c644ff083b6..96a9eab41e7d 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-21.08.3.tar.xz 254604 BLAKE2B 9a7a9c7a1cf82d458c1fd0bbce6b47c233b8a7a20bd1d1696bc75d6b04c8e4a9d6464025d8ad39b3bb96b8dd428fb880a5d318f7c0d13ef3bc8bf24a42c24169 SHA512 2fb7fbd6490d768f3eb7d756429d858337b8088a7c87836ed4a54fc3f863f50c4973bbe2ae149d53d2769d7ce3c31fbd737bc4afc74fd14260a158da83992076
+DIST dolphin-plugins-21.11.90.tar.xz 254640 BLAKE2B c6755fc407b523759c0ac6c362311ee12322efd47e7a5ea4765ee08bc948e532b8e476d35ad2a16390be5150e2f94a5ce6d8cb185718160856bedc081cb4abca SHA512 7e2877666b41cf69dca6c4544a6bf9b6f0d6a09fbcc26c44ca0a3a4521caeda257af41a112ae6e26feb02d1ef7f63f7cd0f417b5b0f04367a65c83391f29dd64
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.11.90.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.11.90.ebuild
new file mode 100644
index 000000000000..0d9df94bf891
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.11.90.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.88.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_bogus_dep Qt5 DBus
+ ecm_punt_bogus_dep KF5 Solid
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}