summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:25:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:28:13 +0100
commit0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac (patch)
tree0e4a9ab3a24db08d0f6c7b61b0d5821e99bd4497 /kde-apps/dolphin-plugins-git
parentecm.eclass: cmake-utils_use_find_package -> cmake_use_find_package (diff)
downloadgentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.gz
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.bz2
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.zip
kde-apps: Add KDE Release Service 19.12.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index c09d2b7fd9d9..e758d5c8c708 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-19.08.3.tar.xz 192608 BLAKE2B 36ad06761a2e016d23af7fcfd206b7d5bd0e07a26f7268dfa40f8f111555c8f41545751c5255d94cab4c8855f3c5e47dacfe762ec4558abc7620f4c6dea1668c SHA512 a9155d8811eebfdaf0e76636746eca20e065d994a7c9e69672e8ebb9cdede118ce518e012e165d3ea82786ee53d46d044e63f208564d2de91b0c8d8c9daf509e
+DIST dolphin-plugins-19.12.0.tar.xz 195968 BLAKE2B 10a294ea3950b14b5593f656d067cf8fbfbf680df7dc96e542f6afcd6c29c50d853fc2ab648a0ca151d342a42c3abc5dcc20dd328e2db1dd2aaf97550ae2226a SHA512 2f02cfd4f5b6596e350a77547f76cb484966393947c2c60940e6570c90121085588b2485ae1e46317b86e6d24189356f123f5243f221217942ede587a2d6400f
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.0.ebuild
new file mode 100644
index 000000000000..e8ad6928e174
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}