summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 20:52:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 21:57:15 +0200
commit493871b6d27cabd3cab07a4a5159ffdf7388c8f4 (patch)
tree4f2d458d33b449723c0f39c753516990841b3c6b /kde-apps/dolphin-plugins-git
parentkde-apps/cervisia: 21.08.2 version bump (diff)
downloadgentoo-493871b6d27cabd3cab07a4a5159ffdf7388c8f4.tar.gz
gentoo-493871b6d27cabd3cab07a4a5159ffdf7388c8f4.tar.bz2
gentoo-493871b6d27cabd3cab07a4a5159ffdf7388c8f4.zip
kde-apps/dolphin-plugins-git: 21.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-21.08.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 2064e0b91290..d779211b335c 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-21.04.3.tar.xz 253244 BLAKE2B c5c0e302dfc4eb82e2de1a635824bf8fd2c70bcac65c261253f0e52e7d9242fa339fe2dc619b927b0379477b2c80a22ec210080af8f2370e0a0182af3347df6a SHA512 e4beba0d596782951b149d42e930d76b12a36bea83f35eb0cff9e49b3e02d4b2aa55f4245d4b8708044a49770d477badc964752828eef4caeaefd4f16e5f9dad
DIST dolphin-plugins-21.08.1.tar.xz 252604 BLAKE2B 9828c3cf690ce54d9ee0be682b7ebf6ac3bd1ec9fd5f73e14c355cf10a19e7e882d3b1a2f3fbdadec8b1f8df926c8bffd566b0cf53a0dafe126b7b70a80ebe6e SHA512 71c0aa8f8207018192853714ca6612f7b56fed9b78d67f940381716ffe60357108a6993326ba67113f66783795d18fd5a68b3bc69b8c449da750d0316e091b52
+DIST dolphin-plugins-21.08.2.tar.xz 253236 BLAKE2B a574e684b7433ea611994ea77ac1b70650760d39d5015cf364a684d4da2b7d7b1ba739f66856c15c3bb9b8d8cf58b2e652762c9844c7af3a2cd983ae8d60727f SHA512 b7b16188dc649b86ffb39d948613b30ad77a3d941706d746bf81609ffa74bc75479abbaa4e5010abf1715cbf52d490145c65398ca91fadd5c31f330f4a1b9f1e
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-21.08.2.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-21.08.2.ebuild
new file mode 100644
index 000000000000..736df8e98190
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-21.08.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_bogus_dep Qt5 DBus
+ ecm_punt_bogus_dep KF5 Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}