summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-23 12:14:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-24 00:06:55 +0200
commit676a79636007840dd187ee278f14c416d27c03fe (patch)
treecb720563f718dd6463117035261bc709a5bc1ce0 /kde-apps/dolphin-plugins-git
parentprofiles: use.desc: Add 'telemetry' (diff)
downloadgentoo-676a79636007840dd187ee278f14c416d27c03fe.tar.gz
gentoo-676a79636007840dd187ee278f14c416d27c03fe.tar.bz2
gentoo-676a79636007840dd187ee278f14c416d27c03fe.zip
kde-apps: Add KDE Release Service 20.04.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 214e1c28b667..b2b6fb180838 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-19.12.3.tar.xz 195464 BLAKE2B b60be81fcb9932f9f645bc614ab74c2e862ef70df6958242dc67de2b9cb570cc8961c2ac593ad99db636f19bec1793316dab21b9cee9a59cf2764b67234c312a SHA512 f6d1ce129095d0ae608b2da4d91f55b93bb8fe94795c09217cc87607bb50cd8dcc5a7dac21b8655f9993da56ef90fa705520c7ac928295edb5254050af9c4a1e
+DIST dolphin-plugins-20.04.0.tar.xz 210308 BLAKE2B 3a2638fe995461dad3f1170181f959de15d6b7fe7b13bcd5b4b116e472f98f301b4de1821dbdd06823a27538c348f16416638120e536a61438f28470843151c0 SHA512 fecd7647661bfc157a41b280a8c32460676597b52e376d7e419c9d74d47a9cc16a6bd621677137f06c201f31c792b61280f1b08fe5b1f8d94bfb36a9b6a2c5cc
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.0.ebuild
new file mode 100644
index 000000000000..738741ae5c09
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.69.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}