summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-06 15:56:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-06 16:33:53 +0100
commit6cdf34a3d24d9669ed06751ca16333f0daff21a3 (patch)
treee0363e0204884cc75be55c81760e69788c00e286 /kde-apps/dolphin-plugins-git
parentnet-vpn/wireguard-tools: bump to 1.0.20200206 (diff)
downloadgentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.tar.gz
gentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.tar.bz2
gentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.zip
kde-apps: Add KDE Release Service 19.12.2
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index bc4bdeac26a6..ccd407b0f2b2 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-19.08.3.tar.xz 192608 BLAKE2B 36ad06761a2e016d23af7fcfd206b7d5bd0e07a26f7268dfa40f8f111555c8f41545751c5255d94cab4c8855f3c5e47dacfe762ec4558abc7620f4c6dea1668c SHA512 a9155d8811eebfdaf0e76636746eca20e065d994a7c9e69672e8ebb9cdede118ce518e012e165d3ea82786ee53d46d044e63f208564d2de91b0c8d8c9daf509e
DIST dolphin-plugins-19.12.1.tar.xz 194676 BLAKE2B 45710e8da5ba6f378dc3eda64f07185e67e6791f59c4ffad628d7678db802dfd9eb4be156e940adfc1e65ffe0351d360c4539c4a56f124fb32fb8603535e609b SHA512 e6bb49acaf6be738510f342700b73c0655147d06667a2b52fc4c4541297603cee66e4239d8c477d8e693c94d860824d6e7f0f9920104476ec5d5796741542b02
+DIST dolphin-plugins-19.12.2.tar.xz 195884 BLAKE2B 5bb575f5c717bb31faceb6f715390a3dc275df5dd526f5edd1cfdf9c2170d235a87dd187e1f14c134806e06c58e0ca946a15dc9cf0fb6f9e9f1e92dd09803941 SHA512 f825b61c0825156d6f0abfefa1ce617135a4bf9521d7feca2a3b677bbcb386d098ceb1c57ca29847e5bfd0e659bf6a2efce3e9a6676e60576f5f58968375ab1a
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.2.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.2.ebuild
new file mode 100644
index 000000000000..c489a07f85f9
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.12.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}