summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 11:21:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 14:22:34 +0200
commit743d14930cd9b8075fb46ec2d65363a2658685f1 (patch)
tree0179b58a3903247814608b279f48053b4cb43a07 /kde-apps/dolphin-plugins-git
parentkde-apps/cervisia: 20.08.1 version bump (diff)
downloadgentoo-743d14930cd9b8075fb46ec2d65363a2658685f1.tar.gz
gentoo-743d14930cd9b8075fb46ec2d65363a2658685f1.tar.bz2
gentoo-743d14930cd9b8075fb46ec2d65363a2658685f1.zip
kde-apps/dolphin-plugins-git: 20.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.08.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index a71bf45f0572..c5a3b6a46c1b 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-20.04.3.tar.xz 213888 BLAKE2B 8ad8e98a42c5a6d12bd3c03ffcc9f5923d1651bc10a74152f5561ebf59b50aafa24fe29d0ea6a7ce147d4f8732fa72c50664b7a890a6e4fe00c64298c8aa0bd4 SHA512 cab1d81deb8204e2d95ae10dc375d5cdc98958ae3dd0a969ee9ea78326229877cd314d2f37266b2ef1ebcdd876cffade6d7e5ee296028867f9c00592c8cd6eb6
DIST dolphin-plugins-20.08.0.tar.xz 227076 BLAKE2B 363636a0ad68b702e905cea14ca06311372b3fb647c57ea59375a859ad95d32cb2dbd851d209b991ffa143b85dcf1594cfd6493defa4886ebad6d201cf63d256 SHA512 4a9578bc9c20c9bcbb282369b7ac6955bdf1de20609762c2d0b396bd24a0a561422eda961f44761f59a2741db8b5191c8c6feb972d4a54a386ebb0fde67de5cb
+DIST dolphin-plugins-20.08.1.tar.xz 228072 BLAKE2B f6d0b0945eb1d9872ef20468e7e8df308d240909eda12bda00181f088c0ede3462f5b8560416500c1f199c1587a544cb65b41b5f89b89f2d493e57d077fc5b73 SHA512 e4f0a8899fd26055a80081236e4a9e14ea5d73c011ee0bf6cc934f599d24047adf86b16ff7164edcc59e101f11ad5364d9381f6852a11d6d36571366ff135e7b
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.08.1.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.08.1.ebuild
new file mode 100644
index 000000000000..90f864399ec2
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.08.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.72.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_bogus_dep Qt5 DBus
+ ecm_punt_bogus_dep KF5 Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}