summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 00:48:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 08:51:28 +0200
commitd91c5589f2317dcfa61e9b15a71341582c6d3537 (patch)
tree13f63c923413004219e299b4f3d4ef39aeffec56 /kde-apps/dolphin-plugins-git
parentkde-frameworks: Add KDE Frameworks 5.71.0 (diff)
downloadgentoo-d91c5589f2317dcfa61e9b15a71341582c6d3537.tar.gz
gentoo-d91c5589f2317dcfa61e9b15a71341582c6d3537.tar.bz2
gentoo-d91c5589f2317dcfa61e9b15a71341582c6d3537.zip
kde-apps: Add KDE Release Service 20.04.2
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index b1e106c5748e..d4742aae170f 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-19.12.3.tar.xz 195464 BLAKE2B b60be81fcb9932f9f645bc614ab74c2e862ef70df6958242dc67de2b9cb570cc8961c2ac593ad99db636f19bec1793316dab21b9cee9a59cf2764b67234c312a SHA512 f6d1ce129095d0ae608b2da4d91f55b93bb8fe94795c09217cc87607bb50cd8dcc5a7dac21b8655f9993da56ef90fa705520c7ac928295edb5254050af9c4a1e
DIST dolphin-plugins-20.04.1.tar.xz 210668 BLAKE2B 5f52ae238e7a4a063b4ef91b092567348c6091c2c29d5ee45d9ce6e31412c257864b4030dbdfb8a9eb536393d0cbc76b38880be753ac0a20d65886f224b21dba SHA512 5dab9c10f3ed93dab83a401c4317dc5f0d4252016d5157a0bb69ff82b2f3f8d4f78a0c65941203b5aaf92d7de8ed8efc903841cffc0024513b8e0e106edc32e3
+DIST dolphin-plugins-20.04.2.tar.xz 211048 BLAKE2B 4ebf63bd4013b0f8bdd7a7548e67d48f4d408fc3d2b76b7ac74b5aee2a792e230f87168b9ce4df4d1788feb46768255e52707c6b2906648bb769e39349943ec1 SHA512 95545db533d2491345cf12f08eb2a615ce5c0aa62550fd49149771c13da3117e670b3e4b86b374631a7b9a404c9cb2ebecfa20ab77d026e1dd94dfde340835cd
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.2.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.2.ebuild
new file mode 100644
index 000000000000..7d7b2b71d718
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.70.0
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}