summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 09:00:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 12:52:52 +0200
commit2f902ba0bda2275e54b21eaa58b03ddde72e0620 (patch)
tree47ad61c2acd383f35c5e5a60a5d7a30102cff620 /kde-apps/kaccounts-integration/kaccounts-integration-22.04.3.ebuild
parentkde-apps/dolphin-plugins-dropbox: 22.04.3 version bump (diff)
downloadgentoo-2f902ba0bda2275e54b21eaa58b03ddde72e0620.tar.gz
gentoo-2f902ba0bda2275e54b21eaa58b03ddde72e0620.tar.bz2
gentoo-2f902ba0bda2275e54b21eaa58b03ddde72e0620.zip
kde-apps/kaccounts-integration: 22.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kaccounts-integration/kaccounts-integration-22.04.3.ebuild')
-rw-r--r--kde-apps/kaccounts-integration/kaccounts-integration-22.04.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/kde-apps/kaccounts-integration/kaccounts-integration-22.04.3.ebuild b/kde-apps/kaccounts-integration/kaccounts-integration-22.04.3.ebuild
new file mode 100644
index 000000000000..ea3ff530480f
--- /dev/null
+++ b/kde-apps/kaccounts-integration/kaccounts-integration-22.04.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=5.92.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.15.4
+VIRTUALDBUS_TEST="true"
+inherit ecm kde.org
+
+DESCRIPTION="Administer web accounts for the sites and services across the Plasma desktop"
+HOMEPAGE="https://community.kde.org/KTp"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ net-libs/accounts-qt
+ >=net-libs/libaccounts-glib-1.21:=
+ net-libs/signond
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+"
+
+# bug #549444
+RESTRICT="test"