summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 17:21:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 17:30:12 +0200
commit7a91ddcc0875608068d07b05af222791d1c6162f (patch)
treef3919075c84fcafa6c3d78e51786e9a540d21d4e /kde-apps/kaccounts-providers
parentnet-mail/courier-imap: version bump to 5.1.2 (diff)
downloadgentoo-7a91ddcc0875608068d07b05af222791d1c6162f.tar.gz
gentoo-7a91ddcc0875608068d07b05af222791d1c6162f.tar.bz2
gentoo-7a91ddcc0875608068d07b05af222791d1c6162f.zip
kde-apps/kaccounts-providers: Add IUSE=webengine (Nextcloud plugin)
Bug: https://bugs.gentoo.org/753274 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kaccounts-providers')
-rw-r--r--kde-apps/kaccounts-providers/files/kaccounts-providers-20.12.3-qtwebengine-optional.patch81
-rw-r--r--kde-apps/kaccounts-providers/kaccounts-providers-20.12.3-r1.ebuild46
-rw-r--r--kde-apps/kaccounts-providers/metadata.xml3
3 files changed, 130 insertions, 0 deletions
diff --git a/kde-apps/kaccounts-providers/files/kaccounts-providers-20.12.3-qtwebengine-optional.patch b/kde-apps/kaccounts-providers/files/kaccounts-providers-20.12.3-qtwebengine-optional.patch
new file mode 100644
index 000000000000..02e5c9ee1d93
--- /dev/null
+++ b/kde-apps/kaccounts-providers/files/kaccounts-providers-20.12.3-qtwebengine-optional.patch
@@ -0,0 +1,81 @@
+From 7a22a7fb85804c834c4597adca4a69dd5a82ffa4 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 4 Apr 2021 17:01:12 +0200
+Subject: [PATCH] Make Qt5WebEngine optional
+
+Qt5WebEngine is a very big package and not easily available on every
+architecture. It should be optional at least when easily possible.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 9 ++++++++-
+ plugins/CMakeLists.txt | 4 +++-
+ providers/CMakeLists.txt | 9 +++++----
+ services/CMakeLists.txt | 9 +++++----
+ 4 files changed, 21 insertions(+), 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3c7207b..906893e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -16,10 +16,17 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+ find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
+ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules" ${ECM_MODULE_PATH})
+
++include(FeatureSummary)
++
+ find_package(Intltool REQUIRED)
+ find_package(KAccounts REQUIRED)
+
+-find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Core Qml WebEngine)
++find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Core Qml)
++find_package(Qt5WebEngine ${QT_REQUIRED_VERSION} CONFIG)
++set_package_properties(Qt5WebEngine
++ PROPERTIES TYPE OPTIONAL
++ PURPOSE "Required for Nextcloud Accounts plugin"
++ )
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED KIO I18n Declarative Package)
+
+ include(KDEInstallDirs)
+diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
+index 3ea1817..f87b8f6 100644
+--- a/plugins/CMakeLists.txt
++++ b/plugins/CMakeLists.txt
+@@ -1,2 +1,4 @@
+ add_subdirectory(owncloud-ui)
+-add_subdirectory(nextcloud-ui)
+\ No newline at end of file
++if(Qt5WebEngine_FOUND)
++ add_subdirectory(nextcloud-ui)
++endif()
+diff --git a/providers/CMakeLists.txt b/providers/CMakeLists.txt
+index 987fb6e..cff3420 100644
+--- a/providers/CMakeLists.txt
++++ b/providers/CMakeLists.txt
+@@ -1,4 +1,5 @@
+-file(GLOB provider_in_files *.provider.in)
+-foreach(provider_in_file ${provider_in_files})
+- kaccounts_add_provider(${provider_in_file})
+-endforeach()
++kaccounts_add_provider(google.provider.in)
++kaccounts_add_provider(owncloud.provider.in)
++if(Qt5WebEngine_FOUND)
++ kaccounts_add_provider(nextcloud.provider.in)
++endif()
+diff --git a/services/CMakeLists.txt b/services/CMakeLists.txt
+index 93e14fc..cc58f91 100644
+--- a/services/CMakeLists.txt
++++ b/services/CMakeLists.txt
+@@ -1,4 +1,5 @@
+-file(GLOB service_files_in *.service.in)
+-foreach(service_file_in ${service_files_in})
+- kaccounts_add_service(${service_file_in})
+-endforeach()
++kaccounts_add_service(owncloud-storage.service.in)
++if(Qt5WebEngine_FOUND)
++ kaccounts_add_service(nextcloud-contacts.service.in)
++ kaccounts_add_service(nextcloud-storage.service.in)
++endif()
+--
+2.31.1
+
diff --git a/kde-apps/kaccounts-providers/kaccounts-providers-20.12.3-r1.ebuild b/kde-apps/kaccounts-providers/kaccounts-providers-20.12.3-r1.ebuild
new file mode 100644
index 000000000000..cb47ffd31dd5
--- /dev/null
+++ b/kde-apps/kaccounts-providers/kaccounts-providers-20.12.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.75.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="KDE accounts providers"
+HOMEPAGE="https://community.kde.org/KTp"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+webengine"
+
+BDEPEND="
+ dev-util/intltool
+"
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/kaccounts-integration-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}
+ net-libs/signon-oauth2
+ net-libs/signon-ui
+"
+
+PATCHES=( "${FILESDIR}/${P}-qtwebengine-optional.patch" ) # bug 753274
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package webengine Qt5WebEngine)
+ )
+ ecm_src_configure
+}
diff --git a/kde-apps/kaccounts-providers/metadata.xml b/kde-apps/kaccounts-providers/metadata.xml
index 2fdbf33d963d..915d461d6529 100644
--- a/kde-apps/kaccounts-providers/metadata.xml
+++ b/kde-apps/kaccounts-providers/metadata.xml
@@ -5,4 +5,7 @@
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <use>
+ <flag name="webengine">Enable Nextcloud KAccounts plugin using <pkg>dev-qt/qtwebengine</pkg></flag>
+ </use>
</pkgmetadata>