summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/kdiamond
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kdiamond')
-rw-r--r--kde-apps/kdiamond/Manifest1
-rw-r--r--kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-1.patch24
-rw-r--r--kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-2.patch33
-rw-r--r--kde-apps/kdiamond/kdiamond-19.08.3.ebuild37
4 files changed, 95 insertions, 0 deletions
diff --git a/kde-apps/kdiamond/Manifest b/kde-apps/kdiamond/Manifest
index 27e6c493f609..91eb3c5a94ed 100644
--- a/kde-apps/kdiamond/Manifest
+++ b/kde-apps/kdiamond/Manifest
@@ -1 +1,2 @@
+DIST kdiamond-19.08.3.tar.xz 4694440 BLAKE2B c5026fb0afbde5368cbc6efb658ab692e6e7d941bed40e10279f4027f335345838bc64d804cc2ac2c52b846380355ef069b817aaaa2b932cef7ea1fe227dc39b SHA512 68fd61fd0212a6605ac891b845b763f4fa9c1b6dae7906d67059d85d99fd7f3a4e30e2333e06dc7c1e4fb026f7ebab9d5cc951b5251e25381896cd52f9b7741d
DIST kdiamond-19.12.3.tar.xz 4693824 BLAKE2B 042f04eb16e3bb45fbf909fe1f683c26a5d06c20267393157ec21d0bd725e8d7c4a6ca0af14bde6ff2147f35618723b488297adc050a0d1dc90289be46eb3297 SHA512 7ed8b8dacdd5e134bd0b6c292d54423680f5613da9fd934690703bb735b5c531bfd9ded79fb43903094b80c0a266dcebc0848148e12f957afcec3cc327104268
diff --git a/kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-1.patch b/kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-1.patch
new file mode 100644
index 000000000000..e0ea1ef57877
--- /dev/null
+++ b/kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-1.patch
@@ -0,0 +1,24 @@
+From df737a7dd5134ba021dc6228fe815974af4a6bfc Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Sun, 8 Sep 2019 21:15:26 +0200
+Subject: GIT_SILENT: QLatin1Literal->QLatin1String
+
+---
+ src/main.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/main.cpp b/src/main.cpp
+index 6afdc2a..5f9f431 100644
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -46,7 +46,7 @@ int main(int argc, char **argv)
+
+ qsrand(time(nullptr));
+ KLocalizedString::setApplicationDomain("kdiamond");
+- KAboutData about(QStringLiteral("kdiamond"), i18nc("The application's name", "KDiamond"), QLatin1Literal(version), i18n(description),
++ KAboutData about(QStringLiteral("kdiamond"), i18nc("The application's name", "KDiamond"), QLatin1String(version), i18n(description),
+ KAboutLicense::GPL, i18n("(C) 2008-2010 Stefan Majewsky and others"), QStringLiteral("http://games.kde.org/kdiamond"));
+ about.addAuthor(i18n("Stefan Majewsky"), i18n("Original author and current maintainer"), QStringLiteral("majewsky@gmx.net"));
+ about.addAuthor(i18n("Paul Bunbury"), i18n("Gameplay refinement"), QStringLiteral("happysmileman@googlemail.com"));
+--
+cgit v1.1
diff --git a/kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-2.patch b/kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-2.patch
new file mode 100644
index 000000000000..9002776d0d08
--- /dev/null
+++ b/kde-apps/kdiamond/files/kdiamond-19.08.3-qt-5.14-2.patch
@@ -0,0 +1,33 @@
+From fe17299b2757d3c0106fbfff325440de0830048f Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Tue, 17 Sep 2019 13:39:44 +0200
+Subject: Make it compiles against qt5.14
+
+---
+ src/game-state.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/game-state.cpp b/src/game-state.cpp
+index c0c35d5..b2c2416 100644
+--- a/src/game-state.cpp
++++ b/src/game-state.cpp
+@@ -19,7 +19,7 @@
+ #include "game-state.h"
+ #include "settings.h"
+
+-#include <QTime>
++#include <QElapsedTimer>
+ #include <KLocalizedString>
+ #include <KNotification>
+
+@@ -32,7 +32,7 @@ public:
+ GameStatePrivate();
+ ~GameStatePrivate();
+
+- QTime m_gameTime, m_pauseTime;
++ QElapsedTimer m_gameTime, m_pauseTime;
+
+ Mode m_mode;
+ State m_state;
+--
+cgit v1.1
diff --git a/kde-apps/kdiamond/kdiamond-19.08.3.ebuild b/kde-apps/kdiamond/kdiamond-19.08.3.ebuild
new file mode 100644
index 000000000000..cdc8e4b3094a
--- /dev/null
+++ b/kde-apps/kdiamond/kdiamond-19.08.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Single player three-in-a-row game"
+HOMEPAGE="https://kde.org/applications/games/kdiamond/
+https://games.kde.org/game.php?game=kdiamond"
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="arm64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-apps/libkdegames-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-qt-5.14-{1,2}.patch )