summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-07 02:31:29 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-13 03:43:01 +1100
commitaf1968b4aaf6d6d0140f334c5814dee109e3e762 (patch)
tree097db3c940167eb06f6eab9114c93f0923296511 /kde-apps/kio-extras
parentdev-lang/ekopath: Add slotted variants of the old versions (diff)
downloadgentoo-af1968b4aaf6d6d0140f334c5814dee109e3e762.tar.gz
gentoo-af1968b4aaf6d6d0140f334c5814dee109e3e762.tar.bz2
gentoo-af1968b4aaf6d6d0140f334c5814dee109e3e762.zip
kde-apps: Move kdecore-meta-15.12.2 and deps from kde overlay
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/kio-extras')
-rw-r--r--kde-apps/kio-extras/Manifest1
-rw-r--r--kde-apps/kio-extras/kio-extras-15.12.2-r1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/kio-extras/Manifest b/kde-apps/kio-extras/Manifest
index 6217e2d82fe3..4499b3584446 100644
--- a/kde-apps/kio-extras/Manifest
+++ b/kde-apps/kio-extras/Manifest
@@ -1 +1,2 @@
DIST kio-extras-15.08.3.tar.xz 266376 SHA256 aeb527fc1290a000b7614e846a478d0096b4ab4a4f24f57aa2c1249d2444515f SHA512 1c565f47cc97b36186048592293f7de736dbdf72b04628e414e283099b3fff7113900a7ec99a1a341ecd05057bcb4e657e9f6d1a9a0092e51efdb521639b2f31 WHIRLPOOL 2b2b3cad75296bda6eb2307531245bdb668f5db88751ce4a963b66950bf3c0d071e0b738520a230a48e663f2c620eb96f6cd3c0a7914a5f14c128ccdfcdbc94e
+DIST kio-extras-15.12.2.tar.xz 266644 SHA256 3b8821e6d5c98f17b4515e7784074663029e64330369df5c64ea81447525461f SHA512 5eb92d9a87953a060d0cbdd2604a1ad7032c01375587c35f6cfdc3eee14b450c254d9797bdc196c6dda946f8bfa09847b9564ee5537575f27050efaf74e7348a WHIRLPOOL 41fcc8baad492a62845cbc8835fb46bcd3f6f4dfdf04bd82a8b492cc7887349095c69e78edc2261e7f999e696302cb4c5da8ebc64d509dc52112813c4144d1ec
diff --git a/kde-apps/kio-extras/kio-extras-15.12.2-r1.ebuild b/kde-apps/kio-extras/kio-extras-15.12.2-r1.ebuild
new file mode 100644
index 000000000000..579b3fdd9437
--- /dev/null
+++ b/kde-apps/kio-extras/kio-extras-15.12.2-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KIO plugins present a filesystem-like view of arbitrary data"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/kio-extras"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="exif mtp openexr phonon samba +sftp slp"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive 'bzip2,lzma')
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kdnssd)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ virtual/jpeg:0
+ exif? ( media-gfx/exiv2:= )
+ mtp? ( media-libs/libmtp:= )
+ openexr? ( media-libs/openexr )
+ phonon? ( media-libs/phonon[qt5] )
+ samba? ( || ( <net-fs/samba-4.0.0_alpha1[smbclient] >=net-fs/samba-4.0.0_alpha1[client] ) )
+ sftp? ( >=net-libs/libssh-0.6.0:=[sftp] )
+ slp? ( net-libs/openslp )
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kded)
+ !<kde-apps/kcontrol-15.08.0-r1:4
+"
+DEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package exif Exiv2)
+ $(cmake-utils_use_find_package mtp Mtp)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ $(cmake-utils_use_find_package phonon Phonon4Qt5)
+ $(cmake-utils_use_find_package samba Samba)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ $(cmake-utils_use_find_package slp SLP)
+ )
+
+ kde5_src_configure
+}