summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-09 19:42:23 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-09 19:42:37 +0100
commit0e7c442531fd2caefa9035ffc99514dc94432083 (patch)
tree7a07bfea1f2927843db5bef673bb696eac1a32a6 /kde-apps/kldap/kldap-16.12.2.ebuild
parentmultiprocess.eclass: makeopts_{jobs,loadavg}: fix implicit handling of $MAKEO... (diff)
downloadgentoo-0e7c442531fd2caefa9035ffc99514dc94432083.tar.gz
gentoo-0e7c442531fd2caefa9035ffc99514dc94432083.tar.bz2
gentoo-0e7c442531fd2caefa9035ffc99514dc94432083.zip
kde-apps: Version bump KDE Applications 16.12.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kldap/kldap-16.12.2.ebuild')
-rw-r--r--kde-apps/kldap/kldap-16.12.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/kldap/kldap-16.12.2.ebuild b/kde-apps/kldap/kldap-16.12.2.ebuild
new file mode 100644
index 000000000000..9620d0882f49
--- /dev/null
+++ b/kde-apps/kldap/kldap-16.12.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library for interacting with LDAP servers"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ net-nds/openldap
+ ssl? ( dev-libs/cyrus-sasl )
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-kioslaves
+"
+
+PATCHES=( "${FILESDIR}/${PN}-16.11.90-unused-dep.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use_if_iuse handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ssl Sasl2)
+ )
+
+ kde5_src_configure
+}