summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:34:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:36:38 +0100
commitc1941078fbe8744f0710332dee5705d3a95a800b (patch)
tree2fbace875e510011c2845a85071b60cf371926d5 /kde-apps/kmag/kmag-18.12.3.ebuild
parentapp-emulation/xen-tools: drop old (diff)
downloadgentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.gz
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.bz2
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.zip
kde-apps: Add KDE Applications 18.12.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-apps/kmag/kmag-18.12.3.ebuild')
-rw-r--r--kde-apps/kmag/kmag-18.12.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-apps/kmag/kmag-18.12.3.ebuild b/kde-apps/kmag/kmag-18.12.3.ebuild
new file mode 100644
index 000000000000..9e8618c2e768
--- /dev/null
+++ b/kde-apps/kmag/kmag-18.12.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="KDE screen magnifier"
+HOMEPAGE="https://www.kde.org/applications/utilities/kmag/"
+KEYWORDS="~amd64 ~x86"
+IUSE="keyboardfocus"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ keyboardfocus? ( media-libs/libqaccessibilityclient:5 )
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/kde4-l10n-17.07.80
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package keyboardfocus QAccessibilityClient)
+ )
+
+ kde5_src_configure
+}