summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-21 18:46:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-21 19:11:10 +0200
commit81993e7ab68f56d999c1a6751fe4e3e6aceadb0e (patch)
tree8545e71362f362c476942995e86621275fb5abde /kde-apps/konsolekalendar
parentkde-apps/knotes: 22.04.0 version bump (diff)
downloadgentoo-81993e7ab68f56d999c1a6751fe4e3e6aceadb0e.tar.gz
gentoo-81993e7ab68f56d999c1a6751fe4e3e6aceadb0e.tar.bz2
gentoo-81993e7ab68f56d999c1a6751fe4e3e6aceadb0e.zip
kde-apps/konsolekalendar: 22.04.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-22.04.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index eaef80c18af4..6d0f8ebe5fcd 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-21.08.3.tar.xz 236480 BLAKE2B 52d684780d95dc0fd957195844ab1a190018a47b62dec05e8bdd3adf565961e6c2b229c46b3ed6cb42e9a81b59800559a1049051eb69ac00cf7cdc98a40f3fb7 SHA512 1f2dc20a9b0d2d8ad35327ebbdf39e382f687120245b346d6b9e03d3c2d521e57208567c5edf6a5552515f62ecf25e0da43fae5bccd41d47114207a30afd5d4c
DIST akonadi-calendar-tools-21.12.3.tar.xz 236308 BLAKE2B f72d8e1170071033c4f155272683eb7687dcdeded97ce26e89139c3b74ccd712651a865006c4e986cc68cdd484e5c7cd12cd29dadf090ae37063bc6d18f34c0a SHA512 7e056a1424869ba0f7ed2c57513365225bce183ac62c4da3e434cf561039c34ca9ba034333dc667bcca516f8204439bebe5f69fe14b004f4de907d8809e6d95b
+DIST akonadi-calendar-tools-22.04.0.tar.xz 236948 BLAKE2B 5949c02b0e4cd38810385a5856dbb06d8a6ca95123a554c0950a488d336114c8b3ce8cddac1579ef245bab085cc7c985b74dcadbb463e04e78643963c90b084b SHA512 5e207e7d7991578bdd12c43bb0affd341b68984a39d0639c761d4194fb52112f67c1acc31b637b4f3e31b9030c7504bbdbef9a1c67c664feca73002c706aab3c
diff --git a/kde-apps/konsolekalendar/konsolekalendar-22.04.0.ebuild b/kde-apps/konsolekalendar/konsolekalendar-22.04.0.ebuild
new file mode 100644
index 000000000000..869bf87c28bb
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-22.04.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}