summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-16 19:38:26 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-16 19:38:38 +0100
commit31645664f42a588800ba68febd89a9c9e6afc76f (patch)
treeccc391e5d2b2b2255adcafe060246a5ddf9a3396 /kde-apps/kopete
parentprofiles: Update masks for KDE Applications 16.12 (diff)
downloadgentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.gz
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.bz2
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.zip
kde-apps: Version bump KDE Applications 16.12.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-16.12.0.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 7d1f71ae2905..554154bc9dbe 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-16.04.3.tar.xz 6328708 SHA256 e34625e2d2b10fe3a12a3a6b1a49a93c32daf96934ee3042538df409087c0abb SHA512 e830ace8ed364d333c72c46fb5ad29d549467afcf6f4563956341ba1651e5c5a91b1ba35a6388d5d428917cf9d086c3a9a0f5121c9bcfa492ec01b5f2c3b4e1b WHIRLPOOL d7b0faeada0f2127055d762032d9d0420bad3e119f1d857dca6590540c7eecab618add45da4b480d79cfbf518c8d1d96f445bd31344d4bf1b97e89509da8d95c
DIST kopete-16.08.3.tar.xz 6334576 SHA256 ff0ed2a29720ef57296011c293694d77da5b3cf6f7d14925b602a055b11f4445 SHA512 66f01cab4838977987821d31186d62f64cccc3edf615a098896cc03badc3be10f5a420e94fcc9057a38515a6181e4751e5c93d53187190c35a80b15ac34652ab WHIRLPOOL e67843427a9e204feed6ab202adad4116817e9a85cc84ef672ab3c34a1caa74eee84110a11d50a5b838dee5c35ca5d73bd9df6494816b58e85f035764911a669
+DIST kopete-16.12.0.tar.xz 6340832 SHA256 c0ecf2c7d2bb679f523d043b27f51120846a812fad8aabfcc6b33c81718f2789 SHA512 7ea765ebb8652773734b98d9287b9a81452d390b86f80b1c34e166491762791666593e68204100cf18b2245f42a4aabcf4c433c02280d116ec814b93613885fe WHIRLPOOL 67f1bb33d2e009e592f69ff462a7e72471b51a68669abad1760921139dcfc74ec12963c410190de7f15a8f0e62f79357f4680aeb756faa37d820b9122268d836
diff --git a/kde-apps/kopete/kopete-16.12.0.ebuild b/kde-apps/kopete/kopete-16.12.0.ebuild
new file mode 100644
index 000000000000..449decdbd592
--- /dev/null
+++ b/kde-apps/kopete/kopete-16.12.0.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
+testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kdelibs 'zeroconf?')
+ $(add_kdeapps_dep kdepimlibs)
+ dev-libs/libpcre
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ media-libs/phonon[qt4]
+ media-libs/qimageblitz
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt4(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/libsrtp
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qjson
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+ winpopup? ( net-fs/samba )
+"
+DEPEND="${COMMONDEPEND}
+ jingle? ( dev-libs/jsoncpp )
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_GOOGLETALK=$(usex jingle)
+ -DWITH_LiboRTP=$(usex jingle)
+ -DWITH_Mediastreamer=$(usex jingle)
+ -DWITH_Speex=$(usex jingle)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ zeroconf) x2=bonjour ;;
+ xmpp) x2=jabber ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF -DWITH_sms=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then # || use irc; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}