summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-13 13:37:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-13 14:21:36 +0200
commite8c04996d5b914e1637db11563cc654009c384fb (patch)
treeecf49f5945169c5456483e6303585550fdee7347 /kde-apps/kopete
parentkde-apps/krfb: 21.04.1 version bump (diff)
downloadgentoo-e8c04996d5b914e1637db11563cc654009c384fb.tar.gz
gentoo-e8c04996d5b914e1637db11563cc654009c384fb.tar.bz2
gentoo-e8c04996d5b914e1637db11563cc654009c384fb.zip
kde-apps/kopete: 21.04.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-21.04.1.ebuild170
2 files changed, 171 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 45a84bccad72..916d8802f9b4 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-20.12.3.tar.xz 9380060 BLAKE2B c9d1f648a924920984f9ddfd8e5d174f034d3621ecd0468debd3689ae3261da32de2beb297513064bbe23477dc4d395371e02761c287302854f582096eaa2984 SHA512 0948547b0e67e67bce1165beb8099ba4c57e3803dfcb37fd6d547e132a449a484bf523f3312aca8cb4477cae8e8c984859313bf0b72bd70799d46e40e510c9fd
DIST kopete-21.04.0.tar.xz 9414048 BLAKE2B a1e2aded6f9082c582f5a232d2a6de98fc61656668c4dcbdb2e7e5734ff5d966814f7c46fb2febdc555ec3bb6f0018b9cd7e7c5b28b63855bc5d8016528282d2 SHA512 8f515210b24a7fe9efd26b702e1318adcb3b62ea4803f177b292f8a3283300e0e2b4a86a3de993819974c80767ebfe1c0522326423b227d21b57aecd1055c7ab
+DIST kopete-21.04.1.tar.xz 9414644 BLAKE2B df0bc4d223b7eddcc32488bb0f1dbb5a916fede9e748efbdab9b02dab8e1cae0b975d068655a61ffac73afa30b7172e7e22326db8e476d36542715618e654bd9 SHA512 5101c594c156f0aa15db50310db7247e1303b96c3cb9c03ed1b8f1b5fd69c9794f0f272ed21cc9c4d97a6b0c6fa2a3c11382b9b53995c373b6fd5d56c1634906
diff --git a/kde-apps/kopete/kopete-21.04.1.ebuild b/kde-apps/kopete/kopete-21.04.1.ebuild
new file mode 100644
index 000000000000..b86a16177140
--- /dev/null
+++ b/kde-apps/kopete/kopete-21.04.1.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.80.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/en/kopete"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="ssl v4l"
+
+# Available plugins
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: BROKEN (app-crypt/gpgme[cxx,qt5], kde-apps/libkleo:5)
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise meanwhile oscar testbed winpopup +xmpp zeroconf"
+
+# disabled protocols
+# irc: NO DEPS
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# skype, sms (until fixed)
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMON_DEPEND="
+ app-crypt/gpgme[cxx,qt5]
+ dev-libs/libpcre
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kemoticons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=media-libs/phonon-4.11.0
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( >=app-crypt/qca-2.3.0:2 )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ >=app-crypt/qca-2.3.0:2
+ net-dns/libidn:0=
+ sys-libs/zlib
+ )
+ zeroconf? (
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ )
+"
+# jingle? (
+# dev-libs/expat
+# dev-libs/openssl:0=
+# >=media-libs/mediastreamer-2.3.0
+# media-libs/speex
+# net-libs/libsrtp:0=
+# net-libs/ortp:=
+# )
+RDEPEND="${COMMON_DEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( >=app-crypt/qca-2.3.0:2[ssl] )
+ xmpp? ( >=app-crypt/qca-2.3.0:2[ssl?] )
+"
+# sms? ( app-mobilephone/smssend )
+# winpopup? ( net-fs/samba )
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+# jingle? ( dev-libs/jsoncpp )
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_qq=OFF
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+# $(cmake_use_find_package jingle LiboRTP)
+# $(cmake_use_find_package jingle Mediastreamer)
+# $(cmake_use_find_package jingle Speex)
+
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ ecm_src_configure
+}