summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/kpimtextedit
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/kpimtextedit')
-rw-r--r--kde-apps/kpimtextedit/Manifest1
-rw-r--r--kde-apps/kpimtextedit/kpimtextedit-18.08.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-apps/kpimtextedit/Manifest b/kde-apps/kpimtextedit/Manifest
index a4ff0adda9bc..79c2b08752e2 100644
--- a/kde-apps/kpimtextedit/Manifest
+++ b/kde-apps/kpimtextedit/Manifest
@@ -1 +1,2 @@
DIST kpimtextedit-18.04.3.tar.xz 142880 BLAKE2B a8ff9679cf54f0445c4fea83ace27774dd801aea2ea11a29031fea906e35f22867cbcffec3e1541d45ec4dbfdc34dde0f508f2bc85d7439707a8b2be0dc0dece SHA512 e8cf0563a2c60bef0b82b0d60a025191c8660c783f262648bc0c9c9c17eb24b5c3c2a0d21159df60009256e920e8a649f06b22815ab051099ba4d6ef145d848e
+DIST kpimtextedit-18.08.1.tar.xz 142980 BLAKE2B f02554e09ae4641f671d20d399dc72d0cfd6e62898fee9cde49f7373957977b4a829f825c83adee48b70a5e0a7be2fd779eb1ed4db0cabb897d40c0ea2cfcfce SHA512 e7830227a74331e399d030dfd8058382329512b85ccd36061d7ddeba2c1eca287d41890847203afb6df254e2d9927fda7974feb4c48ab433f5b037fe48c588f5
diff --git a/kde-apps/kpimtextedit/kpimtextedit-18.08.1.ebuild b/kde-apps/kpimtextedit/kpimtextedit-18.08.1.ebuild
new file mode 100644
index 000000000000..4df08dc9cce6
--- /dev/null
+++ b/kde-apps/kpimtextedit/kpimtextedit-18.08.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="A textedit with PIM-specific features"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/grantlee:5
+ speech? ( $(add_qt_dep qtspeech) )
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( $(add_frameworks_dep ktextwidgets) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}