summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-10 21:19:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-12 23:13:15 +0200
commit83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b (patch)
treeb45546dce283baad7492c85797d5bc6f8e535918 /kde-apps/ktp-call-ui/ktp-call-ui-19.08.2.ebuild
parentkde-frameworks: Add KDE Frameworks 5.63.0 (diff)
downloadgentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.tar.gz
gentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.tar.bz2
gentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.zip
kde-apps: Add KDE Applications 19.08.2
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-call-ui/ktp-call-ui-19.08.2.ebuild')
-rw-r--r--kde-apps/ktp-call-ui/ktp-call-ui-19.08.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/ktp-call-ui/ktp-call-ui-19.08.2.ebuild b/kde-apps/ktp-call-ui/ktp-call-ui-19.08.2.ebuild
new file mode 100644
index 000000000000..ea5c7e4e0955
--- /dev/null
+++ b/kde-apps/ktp-call-ui/ktp-call-ui-19.08.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy audio/video conferencing ui"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/glib:2
+ media-libs/phonon[qt5(+)]
+ media-libs/qt-gstreamer[qt5(+)]
+ net-libs/farstream:0.2
+ net-libs/telepathy-farstream
+ net-libs/telepathy-qt[farstream,qt5(+)]
+"
+# TODO: dep leak suspect
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kcmutils)
+"