summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-17 01:04:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-17 02:06:53 +0200
commitba793210ff7ee6474ac33d823fc195bb6162a942 (patch)
treea0044af76fd1713711642e75a12341f509ecae7d /kde-apps/lokalize
parentkde-apps/kfind: Drop 21.04.3 (r0) (diff)
downloadgentoo-ba793210ff7ee6474ac33d823fc195bb6162a942.tar.gz
gentoo-ba793210ff7ee6474ac33d823fc195bb6162a942.tar.bz2
gentoo-ba793210ff7ee6474ac33d823fc195bb6162a942.zip
kde-apps/lokalize: Drop unused DEPEND
Upstream commit 07fa320da849f9f283ffd707d684e29f1d807405 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/lokalize')
-rw-r--r--kde-apps/lokalize/files/lokalize-21.04.3-unused-dep.patch25
-rw-r--r--kde-apps/lokalize/lokalize-21.04.3-r1.ebuild73
2 files changed, 98 insertions, 0 deletions
diff --git a/kde-apps/lokalize/files/lokalize-21.04.3-unused-dep.patch b/kde-apps/lokalize/files/lokalize-21.04.3-unused-dep.patch
new file mode 100644
index 000000000000..efb230d3a650
--- /dev/null
+++ b/kde-apps/lokalize/files/lokalize-21.04.3-unused-dep.patch
@@ -0,0 +1,25 @@
+From 07fa320da849f9f283ffd707d684e29f1d807405 Mon Sep 17 00:00:00 2001
+From: Alexander Lohnau <alexander.lohnau@gmx.de>
+Date: Sun, 6 Jun 2021 22:29:57 +0200
+Subject: [PATCH] Remove unneeded Qt5::Script find_package call
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1e95619..10bfd6d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,7 +21,7 @@ include(KDECompilerSettings NO_POLICY_SCOPE)
+ include(ECMAddAppIcon)
+ include(ECMQtDeclareLoggingCategory)
+
+-find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core DBus Widgets Script Sql)
++find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core DBus Widgets Sql)
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED I18n KIO XmlGui Notifications Config CoreAddons DocTools Kross Sonnet DBusAddons Crash)
+
+--
+GitLab
+
diff --git a/kde-apps/lokalize/lokalize-21.04.3-r1.ebuild b/kde-apps/lokalize/lokalize-21.04.3-r1.ebuild
new file mode 100644
index 000000000000..a93b5b86e594
--- /dev/null
+++ b/kde-apps/lokalize/lokalize-21.04.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+PYTHON_COMPAT=( python3_{8,9} )
+KFMIN=5.80.0
+QTMIN=5.15.2
+inherit python-single-r1 ecm kde.org optfeature
+
+DESCRIPTION="Localization tool for KDE software and other free and open source software"
+HOMEPAGE="https://apps.kde.org/lokalize/ https://l10n.kde.org/tools/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT+=" test" # tests are broken, bug 739734
+
+DEPEND="${PYTHON_DEPS}
+ >=app-text/hunspell-1.2.8:=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5[sqlite]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kross-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/translate-toolkit[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+PATCHES=( "${FILESDIR}/${P}-unused-dep.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_install() {
+ ecm_src_install
+ rm "${ED}"/usr/share/lokalize/scripts/msgmerge.{py,rc} || die
+ python_fix_shebang "${ED}"/usr/share/${PN}
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "autofetch kde.org translations in new project wizard" dev-vcs/subversion
+ optfeature "spell and grammar checking" app-text/languagetool
+ fi
+ ecm_pkg_postinst
+}