summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 20:11:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 22:30:22 +0100
commit3fa6d920893766911f27b7775c0492b409944e6a (patch)
tree108d14d03f0cae1229fb85b03791e4cc3f3a8bb9 /kde-apps/mailcommon/mailcommon-19.08.3.ebuild
parentkde-frameworks: Add KDE Frameworks 5.64.0 (diff)
downloadgentoo-3fa6d920893766911f27b7775c0492b409944e6a.tar.gz
gentoo-3fa6d920893766911f27b7775c0492b409944e6a.tar.bz2
gentoo-3fa6d920893766911f27b7775c0492b409944e6a.zip
kde-apps: Add KDE Applications 19.08.3
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/mailcommon/mailcommon-19.08.3.ebuild')
-rw-r--r--kde-apps/mailcommon/mailcommon-19.08.3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/mailcommon/mailcommon-19.08.3.ebuild b/kde-apps/mailcommon/mailcommon-19.08.3.ebuild
new file mode 100644
index 000000000000..508ef396813d
--- /dev/null
+++ b/kde-apps/mailcommon/mailcommon-19.08.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Common mail library"
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+BDEPEND="
+ dev-libs/libxslt
+"
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailimporter-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ >=dev-qt/qtxml-${QTMIN}:5
+ media-libs/phonon[qt5(+)]
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+RESTRICT+=" test"