summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 13:14:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 18:58:02 +0100
commit07dec9a033b5a250bc90ffc009c6ff886dc97798 (patch)
tree20b361b5dc949f9a4a3f3087cd8b7f93b97d0e08 /kde-apps/pim-data-exporter/pim-data-exporter-20.08.3.ebuild
parentkde-apps/messagelib: 20.08.3 version bump (diff)
downloadgentoo-07dec9a033b5a250bc90ffc009c6ff886dc97798.tar.gz
gentoo-07dec9a033b5a250bc90ffc009c6ff886dc97798.tar.bz2
gentoo-07dec9a033b5a250bc90ffc009c6ff886dc97798.zip
kde-apps/pim-data-exporter: 20.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pim-data-exporter/pim-data-exporter-20.08.3.ebuild')
-rw-r--r--kde-apps/pim-data-exporter/pim-data-exporter-20.08.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/kde-apps/pim-data-exporter/pim-data-exporter-20.08.3.ebuild b/kde-apps/pim-data-exporter/pim-data-exporter-20.08.3.ebuild
new file mode 100644
index 000000000000..2947cc1efda1
--- /dev/null
+++ b/kde-apps/pim-data-exporter/pim-data-exporter-20.08.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.74.0
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Assistant to backup and archive PIM data and configuration"
+HOMEPAGE="https://apps.kde.org/en/pimdataexporter
+https://userbase.kde.org/KMail/Backup_Options"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="telemetry"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ telemetry? ( dev-libs/kuserfeedback:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ ecm_src_configure
+}