summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-07 20:29:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-07 20:29:32 +0200
commit996987a2817587de8e6dd587fdfdf8897d383ae4 (patch)
treed607e47be660333a574a1618e0f090dd0f0ea60a /kde-apps/pimcommon/pimcommon-17.08.1.ebuild
parentmedia-radio/flrig: Version bump (diff)
downloadgentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.tar.gz
gentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.tar.bz2
gentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.zip
kde-apps: Add KDE Applications 17.08.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/pimcommon/pimcommon-17.08.1.ebuild')
-rw-r--r--kde-apps/pimcommon/pimcommon-17.08.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/pimcommon-17.08.1.ebuild b/kde-apps/pimcommon/pimcommon-17.08.1.ebuild
new file mode 100644
index 000000000000..e08688f90ad2
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-17.08.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/grantlee:5
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ dev-libs/libxslt
+ test? ( $(add_kdeapps_dep kmime) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+PATCHES=( "${FILESDIR}/${PN}-17.04.3-deps.patch" )