summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-06 15:56:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-06 16:33:53 +0100
commit6cdf34a3d24d9669ed06751ca16333f0daff21a3 (patch)
treee0363e0204884cc75be55c81760e69788c00e286 /kde-apps/pimcommon
parentnet-vpn/wireguard-tools: bump to 1.0.20200206 (diff)
downloadgentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.tar.gz
gentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.tar.bz2
gentoo-6cdf34a3d24d9669ed06751ca16333f0daff21a3.zip
kde-apps: Add KDE Release Service 19.12.2
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-19.12.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index 5e71b12ee223..1765d838cc8f 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-19.08.3.tar.xz 293596 BLAKE2B 31326e8df1cce64849f4cd4672aac2df94709416347ad1cd616db2132ff8537f34034574e015ec54b08917dcccd128f2af8fc2d08a54cad8bf1ba0d9e6f7fafe SHA512 844d36c8ed63ec4de7d5feafd637e1d6b87725e77910839365e9a1e8cfdfd2f46e6e64b42a1ca3837a95b2f7a194fde46d5068b0609d5806fea9295b94c1a2b1
DIST pimcommon-19.12.1.tar.xz 294524 BLAKE2B 19d55abd744cea719e4afb9e9f9d42d51987485beb405fbf0990549f7b1105f240873af173ca6277acac23695671660d68a5a8f355ae96d15515385d89b82ebc SHA512 0e595377a6932b6a2962f2126fb3a8bcd56962bca6fe8f654657424c3f392e50449572231b485ba4f7bc82b97fe9a9676557153bd38b04972fa4ae1fd4a30722
+DIST pimcommon-19.12.2.tar.xz 293548 BLAKE2B 7f68af2a410c315dd096d6574d654cabf6e4882f11ab1c3ca35f89e377737c63c09fb6d7dbd9acd968e7a1ac02ee92d9ac27b8d4f425ba9099c3beb2779af056 SHA512 84970405e38c5c742d78bbf256afa5625449985389d2bd7436383f1a4be6b12a51eef1dbd931845b09eaeac184477539fec040f485eca1ed53ae9e0f917863f5
diff --git a/kde-apps/pimcommon/pimcommon-19.12.2.ebuild b/kde-apps/pimcommon/pimcommon-19.12.2.ebuild
new file mode 100644
index 000000000000..344c7e30604c
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-19.12.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Common PIM libraries"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/libxslt
+"
+RDEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/purpose-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/kimap-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+"
+DEPEND="${RDEPEND}
+ test? ( >=kde-apps/kmime-${PVCUT}:5 )
+"
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ ecm_src_test
+}