summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-21 15:39:01 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-21 15:39:45 +0200
commit5e10890b6ebfc31a933ac5829dfad6f723ee0aff (patch)
treea683bc38a6a1d3c0a463b5a2e4d45c87388c01ac /kde-apps/plasma-telepathy-meta
parentprofiles: Mask kde-apps/ktp-text-ui[speech] (diff)
downloadgentoo-5e10890b6ebfc31a933ac5829dfad6f723ee0aff.tar.gz
gentoo-5e10890b6ebfc31a933ac5829dfad6f723ee0aff.tar.bz2
gentoo-5e10890b6ebfc31a933ac5829dfad6f723ee0aff.zip
kde-apps: Add Plasma Telepathy client 15.12.3
Gentoo-bug: 579258 Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-apps/plasma-telepathy-meta')
-rw-r--r--kde-apps/plasma-telepathy-meta/metadata.xml8
-rw-r--r--kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-15.12.3.ebuild41
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-apps/plasma-telepathy-meta/metadata.xml b/kde-apps/plasma-telepathy-meta/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-15.12.3.ebuild b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-15.12.3.ebuild
new file mode 100644
index 000000000000..115038d32162
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-15.12.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5-meta-pkg
+
+DESCRIPTION="Plasma Telepathy client"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-2.1 )"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="nls"
+
+[[ ${KDE_BUILD_TYPE} = live ]] && L10N_MINIMAL=${KDE_APPS_MINIMAL}
+
+RDEPEND="
+ $(add_kdeapps_dep ktp-accounts-kcm)
+ $(add_kdeapps_dep ktp-approver)
+ $(add_kdeapps_dep ktp-auth-handler)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_kdeapps_dep ktp-contact-list)
+ $(add_kdeapps_dep ktp-contact-runner)
+ $(add_kdeapps_dep ktp-desktop-applets)
+ $(add_kdeapps_dep ktp-filetransfer-handler)
+ $(add_kdeapps_dep ktp-kded-module)
+ $(add_kdeapps_dep ktp-send-file)
+ $(add_kdeapps_dep ktp-text-ui)
+ !net-im/kde-telepathy-meta
+ nls? (
+ $(add_kdeapps_dep ktp-l10n '' ${L10N_MINIMAL})
+ )
+"
+
+pkg_postinst() {
+ echo
+ elog "You can configure the accounts in Plasma System Settings"
+ elog "and then add the Instant Messaging plasma applet to access the contact list."
+ echo
+}