summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-22 20:26:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-22 22:10:47 +0200
commit160c2a4c4e63b5976727642ff9c095f77235c257 (patch)
treea09b89db40257b6e59983e8a243810cb012f8620 /kde-apps/thumbnailers
parentkde-apps/svgpart: 22.08.0 version bump (diff)
downloadgentoo-160c2a4c4e63b5976727642ff9c095f77235c257.tar.gz
gentoo-160c2a4c4e63b5976727642ff9c095f77235c257.tar.bz2
gentoo-160c2a4c4e63b5976727642ff9c095f77235c257.zip
kde-apps/thumbnailers: 22.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/thumbnailers')
-rw-r--r--kde-apps/thumbnailers/Manifest1
-rw-r--r--kde-apps/thumbnailers/thumbnailers-22.08.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/Manifest b/kde-apps/thumbnailers/Manifest
index d1d8c28c23d5..ea9dd14e2182 100644
--- a/kde-apps/thumbnailers/Manifest
+++ b/kde-apps/thumbnailers/Manifest
@@ -1 +1,2 @@
DIST kdegraphics-thumbnailers-22.04.3.tar.xz 48468 BLAKE2B b61a6cd5abfa907b9b5c0f41fb328db1a635375229d72f479580db7c395121a3fc2ebf9760a829d138aeef91df2c9d6e75fd5962685d229bbed5e21dc0bf83cd SHA512 b49dbf539e48275954c01434d32fc8d6edd957071104d176de9cc4a044bd69997b936be79499c1bfccc4fe31b9fca9536318527ef7d61c810f7f4d98ffba08a5
+DIST kdegraphics-thumbnailers-22.08.0.tar.xz 49004 BLAKE2B ebbe43e174a8606d959726bea461bbda9169b580d1bab8a92b5aecd73e4f335c6c345903911cc6d422e6d7932c6c365a47edf84cefd66d5b661824f21cc1520f SHA512 25d0146220d18e6b797a2a65676db9c5b3aeb60f7490fb0833b8526a3c789c76a6ce58c2278ece7b60c1fcbe5f1b2d0de6d4fed44d2728f924afea4e5401acb7
diff --git a/kde-apps/thumbnailers/thumbnailers-22.08.0.ebuild b/kde-apps/thumbnailers/thumbnailers-22.08.0.ebuild
new file mode 100644
index 000000000000..ce4b0f7f4f88
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-22.08.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Thumbnail generators for Mobipocket, PDF/PS and RAW files"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="mobi raw"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ mobi? ( >=kde-apps/kdegraphics-mobipocket-${PVCUT}:5 )
+ raw? (
+ >=kde-apps/libkdcraw-${PVCUT}:5
+ >=kde-apps/libkexiv2-${PVCUT}:5
+ )
+"
+RDEPEND="${DEPEND}
+ mobi? ( !<kde-apps/kdegraphics-mobipocket-21.12.50:5[thumbnail] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MOBIPOCKET=$(usex !mobi)
+ $(cmake_use_find_package raw KF5KExiv2)
+ $(cmake_use_find_package raw KF5KDcraw)
+ )
+
+ ecm_src_configure
+}