summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/thumbnailers
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/thumbnailers')
-rw-r--r--kde-apps/thumbnailers/Manifest1
-rw-r--r--kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/Manifest b/kde-apps/thumbnailers/Manifest
index d2bcbbd78949..ce33d8548a76 100644
--- a/kde-apps/thumbnailers/Manifest
+++ b/kde-apps/thumbnailers/Manifest
@@ -1 +1,2 @@
+DIST kdegraphics-thumbnailers-19.08.3.tar.xz 43564 BLAKE2B 823310ac379467405b555a9e111ea717d87ed4f25c2fbbc415c94e7496263e1254d28e8ee1f2a7ad6ff491a32ca803260b88d85ca0fe719bd0bf2e02bdf6659f SHA512 0ad62b71fef59868ef7c4a0486c99495d769bc8e0b364410f4b7cbd0f84bf4c2e24c13a3d398eb210fde0e226a44c1939a4d8aaea2090686bd83d4582bc0df65
DIST kdegraphics-thumbnailers-19.12.3.tar.xz 46452 BLAKE2B d94ae769d22aeeb17b7c3bbef2bdbd3ffd7c25f66876cf73867a28950b0f1fab34a4a9d7ced59d1a71615e9b90e5f47d9f11245af76ed4cfcd48eb7f16bf78cd SHA512 515703d8a22578f09a6e6105e38fc27c0546ad0e61d9c30a052e40a9068f942d586bc8f6411eed0f057f3da0791b94a49a5e378c04ff1f6af20b8c663a154470
diff --git a/kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild b/kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild
new file mode 100644
index 000000000000..98d1f2dfb902
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-19.08.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="arm64"
+IUSE="raw"
+
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ raw? (
+ >=kde-apps/libkdcraw-${PVCUT}:5
+ >=kde-apps/libkexiv2-${PVCUT}:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package raw KF5KExiv2)
+ $(cmake_use_find_package raw KF5KDcraw)
+ )
+
+ ecm_src_configure
+}