summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-02 23:48:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-03 00:32:36 +0200
commit16bb6578f08e3f00144e693e60e2df5e9ccd598a (patch)
tree1c3478da79fa485e17ee6f68d9eed4a9e6a35a0a /kde-apps
parentkde-apps/libkleo: Fix build with GCC-6.3 (diff)
downloadgentoo-16bb6578f08e3f00144e693e60e2df5e9ccd598a.tar.gz
gentoo-16bb6578f08e3f00144e693e60e2df5e9ccd598a.tar.bz2
gentoo-16bb6578f08e3f00144e693e60e2df5e9ccd598a.zip
kde-apps/kleopatra: Fix build with GCC-6.3
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kleopatra/files/kleopatra-4.4.2017.04-gcc-6.3.patch36
-rw-r--r--kde-apps/kleopatra/kleopatra-4.4.2017.04.ebuild2
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-apps/kleopatra/files/kleopatra-4.4.2017.04-gcc-6.3.patch b/kde-apps/kleopatra/files/kleopatra-4.4.2017.04-gcc-6.3.patch
new file mode 100644
index 000000000000..2960166dfb71
--- /dev/null
+++ b/kde-apps/kleopatra/files/kleopatra-4.4.2017.04-gcc-6.3.patch
@@ -0,0 +1,36 @@
+commit 0e75bb7dff48261f8754005586e3d1b22ecfc4d2
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Tue May 2 23:41:46 2017 +0200
+
+ kleopatra: Fix build with GCC 6.3.0
+
+ Signed-off-by: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+
+diff --git a/kleopatra/utils/stl_util.h b/kleopatra/utils/stl_util.h
+index 35024d398f..c02188608e 100644
+--- a/kleopatra/utils/stl_util.h
++++ b/kleopatra/utils/stl_util.h
+@@ -347,7 +347,7 @@ namespace kdtools {
+ template <typename O, typename I, typename P>
+ O copy_if( const I & i, P p ) {
+ O o;
+- copy_if( boost::begin( i ), boost::end( i ), std::back_inserter( o ), p );
++ kdtools::copy_if( boost::begin( i ), boost::end( i ), std::back_inserter( o ), p );
+ return o;
+ }
+
+@@ -385,12 +385,12 @@ namespace kdtools {
+
+ template <typename C>
+ bool none_of( const C & c ) {
+- return none_of( boost::begin( c ), boost::end( c ) );
++ return kdtools::none_of( boost::begin( c ), boost::end( c ) );
+ }
+
+ template <typename C, typename P>
+ bool none_of( const C & c, P p ) {
+- return none_of( boost::begin( c ), boost::end( c ), p );
++ return kdtools::none_of( boost::begin( c ), boost::end( c ), p );
+ }
+
+ template <typename C, typename B>
diff --git a/kde-apps/kleopatra/kleopatra-4.4.2017.04.ebuild b/kde-apps/kleopatra/kleopatra-4.4.2017.04.ebuild
index 8cb2925d73b9..7336129e7068 100644
--- a/kde-apps/kleopatra/kleopatra-4.4.2017.04.ebuild
+++ b/kde-apps/kleopatra/kleopatra-4.4.2017.04.ebuild
@@ -34,6 +34,8 @@ KMEXTRACTONLY="
"
KMLOADLIBS="libkleo"
+PATCHES=( "${FILESDIR}/${P}-gcc-6.3.patch" )
+
src_unpack() {
if use handbook; then
KMEXTRA="