summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 13:13:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 18:57:44 +0100
commit346fa6b10ec7b2e1b01ba3dc9d123af22051b67d (patch)
tree3683ba193116b05884680e12accef0dce6353dee /kde-apps
parentkde-apps/kipi-plugins: 20.08.3 version bump (diff)
downloadgentoo-346fa6b10ec7b2e1b01ba3dc9d123af22051b67d.tar.gz
gentoo-346fa6b10ec7b2e1b01ba3dc9d123af22051b67d.tar.bz2
gentoo-346fa6b10ec7b2e1b01ba3dc9d123af22051b67d.zip
kde-apps/kolourpaint: 20.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-20.08.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index 5a2622c6a3fc..56f4d9bd3755 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1,2 +1,3 @@
DIST kolourpaint-20.04.3.tar.xz 5651568 BLAKE2B 30b550a0c41b4414a474f8a068a5681cfebe12d03bd7e2260ea39aeb8ca331fa7301b6adf414a8aafc42579d2460dd5549ea5955d30941aca4d6b17d45c524d5 SHA512 fdefd7de9cbb65f791b1cd243d60a3ed81994b6ae4243a76efe024d7259e64f214f5bb6d67e6dfdc7339dd6dec93bb2498d0b4a3e80104b89022bd881ad0a1a1
DIST kolourpaint-20.08.2.tar.xz 5686648 BLAKE2B 1eed91f67e646e172c92e6c40cfff3c7aa004b5d937bad6f7967ea3f691503f08883640f7e1cbae5f18a81853c47fe28ee2c25fbf50da812383cfa2a375315c1 SHA512 04cd4f5e34e59097658921816216b2653926697b30659d8c3ae81a81ad5a4c18269e95bb66e7f62dcd80b3ed0656b0f8ef265524ce583dc6427bc5d8996e19b5
+DIST kolourpaint-20.08.3.tar.xz 5686628 BLAKE2B 6155d5c953332e44a3ec44b604fa1c780f8407e826c10ab4900968a30705e059272d0c6a0c022b3804fd0f36b041e41390fd3d93900e401e6492b6e35ebb464e SHA512 ed891626b0638bc6accb511467e9135bb50420d1ec26913940435f763fd01575af2ed6ac7a3a4256d657045a9211ffc665d7ec87606d7760125b8ebd6814b69f
diff --git a/kde-apps/kolourpaint/kolourpaint-20.08.3.ebuild b/kde-apps/kolourpaint/kolourpaint-20.08.3.ebuild
new file mode 100644
index 000000000000..2e5027deef8a
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-20.08.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.74.0
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://apps.kde.org/en/kolourpaint"
+
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="scanner"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ scanner? ( >=kde-apps/libksane-${PVCUT}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package scanner KF5Sane)
+ )
+
+ ecm_src_configure
+}