summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-11 16:34:12 +0000
committerSam James <sam@gentoo.org>2022-12-11 16:34:12 +0000
commit6005fccc74402b5e8020849c6de99f044be6c671 (patch)
treeb15513cf2ef04d153935842d89bd65555b7f9444 /kde-apps
parentkde-apps/kitinerary: fix build w/ gcc 13 (diff)
downloadgentoo-6005fccc74402b5e8020849c6de99f044be6c671.tar.gz
gentoo-6005fccc74402b5e8020849c6de99f044be6c671.tar.bz2
gentoo-6005fccc74402b5e8020849c6de99f044be6c671.zip
kde-apps/kdenetwork-filesharing: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/885315 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kdenetwork-filesharing/files/kdenetwork-filesharing-22.12.0-gcc13.patch24
-rw-r--r--kde-apps/kdenetwork-filesharing/kdenetwork-filesharing-22.12.0.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/kde-apps/kdenetwork-filesharing/files/kdenetwork-filesharing-22.12.0-gcc13.patch b/kde-apps/kdenetwork-filesharing/files/kdenetwork-filesharing-22.12.0-gcc13.patch
new file mode 100644
index 000000000000..309108854e24
--- /dev/null
+++ b/kde-apps/kdenetwork-filesharing/files/kdenetwork-filesharing-22.12.0-gcc13.patch
@@ -0,0 +1,24 @@
+https://invent.kde.org/network/kdenetwork-filesharing/-/commit/5c2d4ff3092155d24164c24a2a9a610325ff7174
+
+From: Sam James <sam@gentoo.org>
+Date: Sun, 11 Dec 2022 13:23:56 +0000
+Subject: [PATCH] samba: Fix build with GCC 13 (add missing <cstdint> include)
+
+GCC 13 (as usual for new compiler releases) shuffles around some
+internal includes and so <cstdint> is no longer transitively included.
+
+Explicitly include <cstdint> for uint32_t.
+
+Bug: https://bugs.gentoo.org/885315
+--- a/samba/aclproperties/debug.h
++++ b/samba/aclproperties/debug.h
+@@ -3,6 +3,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+
+ struct ACE;
+--
+GitLab
diff --git a/kde-apps/kdenetwork-filesharing/kdenetwork-filesharing-22.12.0.ebuild b/kde-apps/kdenetwork-filesharing/kdenetwork-filesharing-22.12.0.ebuild
index 4ef9907b39d7..64e0b56b8172 100644
--- a/kde-apps/kdenetwork-filesharing/kdenetwork-filesharing-22.12.0.ebuild
+++ b/kde-apps/kdenetwork-filesharing/kdenetwork-filesharing-22.12.0.ebuild
@@ -31,6 +31,10 @@ RDEPEND="${DEPEND}
net-fs/samba
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-22.12.0-gcc13.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON