summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-12-09 21:19:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-12-09 21:54:53 +0100
commit64fdafd8278b62cc4e8cf313be4913388a9cea13 (patch)
treeabe254c7e680f5488e58af5f8a0e2f670a893cb2 /kde-apps
parentkde-apps/kwalletmanager: 22.12.0 version bump (diff)
downloadgentoo-64fdafd8278b62cc4e8cf313be4913388a9cea13.tar.gz
gentoo-64fdafd8278b62cc4e8cf313be4913388a9cea13.tar.bz2
gentoo-64fdafd8278b62cc4e8cf313be4913388a9cea13.zip
kde-apps/print-manager: 22.12.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-22.12.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 506f97c36e18..8fe3b50480a9 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-22.08.3.tar.xz 278784 BLAKE2B e62410cba4ec3212988f17d7f7af9d1517398b381d2cbffcba47bf08afda722e48d5db1810abc0a2fe3e1c0ecb5142fc5369b38d558c09a0974f7da1d10e5cfe SHA512 3c053af253ed6014fd0974baa08d7d69de466a1eedede17d3bb3f95a274b7a51b106637b7ac633a043b2fd2e995a49f33e4997b85f1dfb20c1a60a3be9db93ac
+DIST print-manager-22.12.0.tar.xz 287320 BLAKE2B 24d7cce232ec4c6abbe51760681a888abf9f0b1a344db938e09b4b630de1d68bb7306f4863061c57897b245da112ba38cfbb9fb551de680dca07718e23de9a63 SHA512 d759cd8c6330f34fff6223c9c365ea3a58de01306741acf64686c98c90bb83c93971a69b81e24f8e1e7df6ad2a2fe3a3a7afda6ffae73dea4f4354fd60cef8a5
diff --git a/kde-apps/print-manager/print-manager-22.12.0.ebuild b/kde-apps/print-manager/print-manager-22.12.0.ebuild
new file mode 100644
index 000000000000..4e03a69fc115
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-22.12.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ kde-plasma/kde-cli-tools:5
+ gtk? ( app-admin/system-config-printer )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}