summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-08-25 23:26:45 +1000
committerMichael Palimaka <kensington@gentoo.org>2015-08-25 23:27:29 +1000
commitb73904cd45fca09010de29a002db6a47870ec036 (patch)
treee523cbb3f53525eb041fcb6f3f2e315ad11e9e22 /kde-apps
parentdev-libs/libdbusmenu-qt: amd64 stable wrt bug #558660 (diff)
downloadgentoo-b73904cd45fca09010de29a002db6a47870ec036.tar.gz
gentoo-b73904cd45fca09010de29a002db6a47870ec036.tar.bz2
gentoo-b73904cd45fca09010de29a002db6a47870ec036.zip
kde-apps/konsole: introduce minimal USE flag for Plasma 5 compatibility.
Enabling it strips the components colliding with konsole:5, leaving effectively only konsolepart. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/konsole/konsole-4.14.3.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/kde-apps/konsole/konsole-4.14.3.ebuild b/kde-apps/konsole/konsole-4.14.3.ebuild
index 0c4bd47661a4..e1a86c6ac599 100644
--- a/kde-apps/konsole/konsole-4.14.3.ebuild
+++ b/kde-apps/konsole/konsole-4.14.3.ebuild
@@ -13,7 +13,7 @@ inherit kde4-base
DESCRIPTION="X terminal for use with KDE"
HOMEPAGE="https://www.kde.org/applications/system/konsole https://konsole.kde.org"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug"
+IUSE="debug minimal"
COMMONDEPEND="
!aqua? (
@@ -36,3 +36,12 @@ RDEPEND="${COMMONDEPEND}"
# can't connect to a kded instance, fails to connect to dbus
RESTRICT="test"
+
+src_install() {
+ kde4-base_src_install
+
+ if use minimal; then
+ rm "${D}/usr/bin/konsole" || die
+ rm "${D}/usr/bin/konsoleprofile" || die
+ fi
+}