summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/plasma-workspace/plasma-workspace-4.11.19.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/plasma-workspace/plasma-workspace-4.11.19.ebuild')
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.11.19.ebuild122
1 files changed, 122 insertions, 0 deletions
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.11.19.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.11.19.ebuild
new file mode 100644
index 000000000000..13967cda0c76
--- /dev/null
+++ b/kde-base/plasma-workspace/plasma-workspace-4.11.19.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+KMMODULE="plasma"
+PYTHON_COMPAT=( python2_7 )
+OPENGL_REQUIRED="always"
+inherit python-single-r1 kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug gps json +kdepim nepomuk python qalculate"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMONDEPEND="
+ dev-libs/libdbusmenu-qt
+ >=dev-qt/qtcore-4.8.4-r3:4
+ !kde-misc/ktouchpadenabler
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs 'nepomuk?')
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep ksysguard)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep libplasmaclock 'kdepim?')
+ $(add_kdebase_dep libplasmagenericshell)
+ $(add_kdebase_dep libtaskmanager)
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ gps? ( >=sci-geosciences/gpsd-2.37 )
+ json? ( dev-libs/qjson )
+ kdepim? ( $(add_kdebase_dep kdepimlibs) )
+ nepomuk? (
+ dev-libs/soprano
+ $(add_kdebase_dep nepomuk-core)
+ )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt4-4.4.0[X,${PYTHON_USEDEP}]
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+ qalculate? ( sci-libs/libqalculate )
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}
+ $(add_kdeapps_dep plasma-runtime)
+"
+
+KMEXTRA="
+ appmenu/
+ ktouchpadenabler/
+ statusnotifierwatcher/
+"
+KMEXTRACTONLY="
+ kcheckpass/
+ krunner/dbus/org.freedesktop.ScreenSaver.xml
+ krunner/dbus/org.kde.krunner.App.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ ksmserver/screenlocker/
+ libs/kephal/
+ libs/kworkspace/
+ libs/taskmanager/
+ libs/plasmagenericshell/
+ libs/ksysguard/
+ libs/kdm/kgreeterplugin.h
+ ksysguard/
+"
+
+pkg_setup() {
+ if use python ; then
+ python-single-r1_pkg_setup
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+=" doc/plasma-desktop"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gps libgps)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with kdepim Akonadi)
+ $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with nepomuk NepomukCore)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_with python PythonLibrary)
+ $(cmake-utils_use_with qalculate)
+ -DWITH_Xmms=OFF
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ if use python; then
+ python_optimize "${ED}"
+ fi
+}