summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 10:07:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 10:36:53 +0100
commitfbd7c59d80e6367a5d552078606b32b3b53b2ceb (patch)
tree8b6fff35ab097839390f939d37ad6eb0c0f050e3 /kde-frameworks/extra-cmake-modules
parentkde-frameworks/extra-cmake-modules: FindQHelpGenerator: Find Qt5Help (diff)
downloadgentoo-fbd7c59d80e6367a5d552078606b32b3b53b2ceb.tar.gz
gentoo-fbd7c59d80e6367a5d552078606b32b3b53b2ceb.tar.bz2
gentoo-fbd7c59d80e6367a5d552078606b32b3b53b2ceb.zip
kde-frameworks/extra-cmake-modules: Drop 5.52.0 (r0)
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/extra-cmake-modules')
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.52.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.52.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.52.0.ebuild
deleted file mode 100644
index 4f32e710baca..000000000000
--- a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.52.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
-ECM_KDEINSTALLDIRS="false"
-KDE_AUTODEPS="false"
-KDE_DEBUG="false"
-KDE_QTHELP="false"
-KDE_TEST="false"
-inherit kde5 python-any-r1
-
-DESCRIPTION="Extra modules and scripts for CMake"
-HOMEPAGE="https://cgit.kde.org/extra-cmake-modules.git"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-IUSE="doc test"
-
-DEPEND="
- doc? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
- )
- test? (
- $(add_qt_dep qtcore)
- $(add_qt_dep linguist-tools)
- )
-"
-RDEPEND="
- app-arch/libarchive[bzip2]
-"
-
-PATCHES=( "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch" )
-
-python_check_deps() {
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_QTHELP_DOCS=$(usex doc)
- -DBUILD_HTML_DOCS=$(usex doc)
- -DBUILD_MAN_DOCS=$(usex doc)
- -DDOC_INSTALL_DIR=/usr/share/doc/"${PF}"
- )
- use test && mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON )
-
- kde5_src_configure
-}
-
-src_test() {
- # ECMToolchainAndroidTest passes but then breaks src_install
- # ECMPoQmToolsTest is broken, bug #627806
- local myctestargs=(
- -E "(ECMToolchainAndroidTest|ECMPoQmToolsTest)"
- )
-
- kde5_src_test
-}