summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 00:36:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 08:51:25 +0200
commit9efd24de6c1fdb4a027b91db473262aba16731e0 (patch)
tree2b546c79713a9915fb32d1fd0542ba5c5354ed81 /kde-frameworks/frameworkintegration
parentprofiles: mask ruby 2.4 for removal (diff)
downloadgentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.gz
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.bz2
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.zip
kde-frameworks: Add KDE Frameworks 5.71.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 15fe5db26b36..ea535fc45da6 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.70.0.tar.xz 1753940 BLAKE2B 5da86d4b7fe8a696e217273ff468c668ec1e04c138dd756a0a9280fbd6acb99f9cbd3bbce1790886de50335d036e7a99a83f1ea4ad4103101ecc46878d0e071b SHA512 70a72388315c0ca1625bb279b15a9df1693aed9a6dd470af8744b856e5c7cc458b0ffcc384489889e8c3e753edb03062b41cc688361498e45ac3a26d7be70a34
+DIST frameworkintegration-5.71.0.tar.xz 1754420 BLAKE2B 29e26fb31a5f2480428c2610d9f6a77d8ab37b5305ad82d7eb0cd1cc0b229257d00fc11632dfb45e61fae2723879fa24bbe8bcbb165cd211e59b404328ca8ab5 SHA512 a6a934acd284df0f2e5842eec851ae77890d40ea6e9d7a9e7205c10b746057f908d1e19ef405a783d15eb64656e98b074a0794bacdf89ab830f2c7f70bf91838
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild
new file mode 100644
index 000000000000..9f5ba007e2d5
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.71.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.15.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}