summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-15 12:53:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-15 17:21:09 +0100
commit8d97c0a8eecf7ec0e2a720705ba48106b1eae076 (patch)
treea975761f9dd47e8fd43608678eb97a63a7d175a3 /kde-frameworks/karchive/karchive-5.113.0.ebuild
parentkde-frameworks/kapidox: 5.113.0 version bump (diff)
downloadgentoo-8d97c0a8eecf7ec0e2a720705ba48106b1eae076.tar.gz
gentoo-8d97c0a8eecf7ec0e2a720705ba48106b1eae076.tar.bz2
gentoo-8d97c0a8eecf7ec0e2a720705ba48106b1eae076.zip
kde-frameworks/karchive: 5.113.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/karchive/karchive-5.113.0.ebuild')
-rw-r--r--kde-frameworks/karchive/karchive-5.113.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/karchive/karchive-5.113.0.ebuild b/kde-frameworks/karchive/karchive-5.113.0.ebuild
new file mode 100644
index 000000000000..bb4a02521a12
--- /dev/null
+++ b/kde-frameworks/karchive/karchive-5.113.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for reading, creation, and manipulation of various archive formats"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+zstd"
+
+DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/linguist-tools-${QTMIN}:5
+ zstd? ( virtual/pkgconfig )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # TODO: try to get a build switch upstreamed
+ if ! use zstd; then
+ sed -e "s/^pkg_check_modules.*LibZstd/#&/" -i CMakeLists.txt || die
+ fi
+}