summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-10 23:00:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-11 00:03:10 +0100
commit1745e25690dfcb3b3778b0765952a0e744606063 (patch)
tree699a5cb50c0a5be9975405458cc9dec3dd9fe811 /kde-frameworks/karchive/karchive-5.248.0.ebuild
parentkde-frameworks/extra-cmake-modules: 5.248.0 version bump (diff)
downloadgentoo-1745e25690dfcb3b3778b0765952a0e744606063.tar.gz
gentoo-1745e25690dfcb3b3778b0765952a0e744606063.tar.bz2
gentoo-1745e25690dfcb3b3778b0765952a0e744606063.zip
kde-frameworks/karchive: 5.248.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/karchive/karchive-5.248.0.ebuild')
-rw-r--r--kde-frameworks/karchive/karchive-5.248.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/karchive/karchive-5.248.0.ebuild b/kde-frameworks/karchive/karchive-5.248.0.ebuild
new file mode 100644
index 000000000000..1bdb50c94726
--- /dev/null
+++ b/kde-frameworks/karchive/karchive-5.248.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for reading, creation, and manipulation of various archive formats"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64"
+IUSE="+zstd"
+
+DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qttools-${QTMIN}:6[linguist]
+ zstd? ( virtual/pkgconfig )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # TODO: try to get a build switch upstreamed
+ if ! use zstd; then
+ sed -e "s/^pkg_check_modules.*LibZstd/#&/" -i CMakeLists.txt || die
+ fi
+}