summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 13:48:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 14:37:36 +0200
commitb5ffa0d779cee8fdaf27f728378f89c60244dd78 (patch)
treefa18e9e9d888fdf69eeb7a7b54e2db05b947b4ae /kde-frameworks/kauth/kauth-5.74.0.ebuild
parentkde-frameworks/kactivities: 5.74.0 version bump (diff)
downloadgentoo-b5ffa0d779cee8fdaf27f728378f89c60244dd78.tar.gz
gentoo-b5ffa0d779cee8fdaf27f728378f89c60244dd78.tar.bz2
gentoo-b5ffa0d779cee8fdaf27f728378f89c60244dd78.zip
kde-frameworks/kauth: 5.74.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth/kauth-5.74.0.ebuild')
-rw-r--r--kde-frameworks/kauth/kauth-5.74.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/kauth-5.74.0.ebuild b/kde-frameworks/kauth/kauth-5.74.0.ebuild
new file mode 100644
index 000000000000..9148d3efcbac
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.74.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0 )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}