summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-08-14 04:58:31 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-08-14 04:59:46 +1000
commit57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b (patch)
tree2df6d3acd4cca42d1875342669d68e48a488a80c /kde-frameworks/kauth
parentmate-extra/mate-screensaver: Drop gtk3 dep for mate-session-manager (diff)
downloadgentoo-57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b.tar.gz
gentoo-57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b.tar.bz2
gentoo-57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b.zip
kde-frameworks: version bump 5.25.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.25.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 5dd31ee5199a..4e1a6026b378 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.23.0.tar.xz 82708 SHA256 7788efd5710b939c302bb461681bcf47d55a39767ea15d5cdb760cf07c2fefa9 SHA512 15ed7416ec1c507c5e2eeaafb7042db2687d646ee362445be8040547f58629391698be02b9d3a84b1e5b19a4a0d54a31ae740ed43e4e0b956f6c4a27d59bc8a2 WHIRLPOOL 2333ced83580f157ccdd8089173e09b16b0a0fe565b1d99362f40999331c202ac75e2449c69e3d65085b48a61d5f79980f7371db0b3b57603ce2575966227267
DIST kauth-5.24.0.tar.xz 82704 SHA256 896818eb3262d2bd8cd62e973c0ab4b9a2662fc4899f9319f638ab419f935293 SHA512 8067f0173b377ef012b586f2194941180f6fd3e54fc8cf48f77dbe5349d723912a69dc1361f71209a2f0f77471fe04c43e2dbb6d2a7ba38c7bdba55c2ff6b926 WHIRLPOOL 7c0fdfe6fe65d74b84df541edfc091a88667c46b8c8a3659c6652e205052a0738e0da72bcc65951f7f4c480b6ab3d8200754a1a5aef11671c85121ba7b407dbd
+DIST kauth-5.25.0.tar.xz 82708 SHA256 1d62b32d88ba6c1e71e7b3ef67366710b9ce4488bcf82280fbe70d79b52f963a SHA512 3f3c966b7744af8d8cff90eb08460d9b30011d1becf8e0ad3a77615e7e4db5fff692ad99506eaee17e790e98d1d4df3c3a2e8d2ca5814d7b967830ec858ede70 WHIRLPOOL 8db008bf380b3977a6e3a35f9290453d945f3f1ff149bb30557c00450ba31843995effc669c343c4ce903a65833deadd808504489567c0e408ad54f5784b9954
diff --git a/kde-frameworks/kauth/kauth-5.25.0.ebuild b/kde-frameworks/kauth/kauth-5.25.0.ebuild
new file mode 100644
index 000000000000..51e0db8d769f
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.25.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls +policykit"
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus '' '' '5=')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}