summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-12 18:28:03 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-12 18:28:19 +0100
commit4b160993f90db90a69e37baff8977a24177cc48c (patch)
treebb0e84333f2b17fc242263e06515cfa97425afd6 /kde-frameworks/kcrash/kcrash-5.29.0.ebuild
parentmedia-sound/puddletag: Version bump. (diff)
downloadgentoo-4b160993f90db90a69e37baff8977a24177cc48c.tar.gz
gentoo-4b160993f90db90a69e37baff8977a24177cc48c.tar.bz2
gentoo-4b160993f90db90a69e37baff8977a24177cc48c.zip
kde-frameworks: Version bump KDE Frameworks 5.29.0
Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.29.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.29.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.29.0.ebuild b/kde-frameworks/kcrash/kcrash-5.29.0.ebuild
new file mode 100644
index 000000000000..ff491a5217bc
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.29.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls X"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtwidgets) )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}